No Power to Pcm - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 1Likes
  • 1 Post By Coby7
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-28-2016, 07:55 PM Thread Starter
Newcomer
 
Join Date: Oct 2016
Posts: 2
No Power to Pcm

2005 cobalt ss wirh 104k on her. It's ran fine. Started fine. I was out Wednesday running errands. Left my 2nd destination and car shut off at 40 mph or so. I coasted and tried to restart. Nothing happened. No click, nothing from starter. All acessories work tho

Took to mechanic. Obd2 port gets power but pcm isn't showing up on his scanner. There also is no power going to pcm fuse.

Checked g103 ground that grounds pcm. He said it's good. Does anyone have schematics? Know where pcm gets its power from so we can start somewhere?
Jim Lewis is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-29-2016, 01:07 PM
Prospect
 
Join Date: Apr 2016
Posts: 14
Hi
I hope I could help ,
I have had same type of problems with thing s not working on my cobalt,
start with the bcm fuse s under the hood on the top left side corner you have a 30 amp and a 40 amp ,fuse
all info is on the under side of the fuse box top were every thing is ,
even if it looks ok it may not be ,change it with another fuse and see what happens,
these 2 seem to control the car ,then start with the relays and check every fuse one by one ,it may have come up or is dirty around it ,then go from there .

hope this helps
white is offline  
post #3 of 4 (permalink) Old 10-29-2016, 01:34 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Check and make sure your boost post is tight.
Jim Lewis likes this.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
 
post #4 of 4 (permalink) Old 10-30-2016, 11:25 AM Thread Starter
Newcomer
 
Join Date: Oct 2016
Posts: 2
I'm thinking it's the engine fuse box. All fuses and relays are good. Mechanic loosened it up and wiggled the wires and my dash did light up with some lights it is missing. Peoblem is, it's not at house for me to tinker with. But he said he's diving into it tomorrow. There were some wires rhat had the coating stripped off also. I'm hoping that's the problem
Jim Lewis is offline  
Sponsored Links
Advertisement
 
Closed Thread

Tags
cobalt ss , pcm , stalled

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome