Front Passenger Blinker Issue - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-06-2016, 07:56 PM Thread Starter
Newcomer
 
Join Date: Dec 2016
Location: New Jersey
Posts: 5
Front Passenger Blinker Issue

Okay so let me give you a little background on this.
I just recently bought a 2008 Cobalt SS Turbocharged 5 speed manual. Car only has 52k miles on it. Runs wonderful. Its a joy to drive. About two days after I bought it, the front passenger headlight blew. It didnt just go out. It literally blew up. I have glass on the interior of my healight now. I replaced the healight, it works fine. Well today, the very next day, my front passenger blinker went out. Okay. I went and got new blinker bulbs and replaced my bulbs. IT STILL DOESNT WORK. My parking lights work. Every other blinker on the vehicle works. My hazards work. The fuses are fine. I've double and triple checked everything. My damn blinker still doesnt work. There is condensation built up in the headlight. We have drained it and dried it out. Id say that was the issue but then my parking lights/running light wouldnt work too right? Any advice is more than welcome. Im pretty good at working on my own car so not being able to fix this is driving me nuts and its something that can potentially get me a ticket. Thanks in advance!
Virus1358 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-07-2016, 05:28 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
If hazards work you know it's not the bulb, connector or wiring. You also clear the BCM output since that's also the same as hazard. It leaves the lever but this would mean rear blinker is also not working and the right arrow in the cluster..

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #3 of 4 (permalink) Old 12-07-2016, 05:20 PM Thread Starter
Newcomer
 
Join Date: Dec 2016
Location: New Jersey
Posts: 5
Exactly why Im so confused. Im starting to think its more a lose wire or bare wire maybe? Im baffled by this.
Virus1358 is offline  
 
post #4 of 4 (permalink) Old 12-07-2016, 05:22 PM Thread Starter
Newcomer
 
Join Date: Dec 2016
Location: New Jersey
Posts: 5
I should have noted that when i turn on my hazards, every blinker works except front passenger. sorry
Virus1358 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome