Water Not Flowing in Engine - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-06-2017, 03:43 PM Thread Starter
Newcomer
 
Join Date: Nov 2015
Posts: 4
Water Not Flowing in Engine

Hey,

Just replaced my waterpump after finding it damaged and now I am having a problem with overflow in the surge tank after running the engine at 2500rpm for about 3 mins. It doesnt look like the engines is overheating though. Its not a head gasket problem. After removing the heater core inlet/outlet hoses, a mechanic said the problem was there was no water flow. Took it to chevy, and they said it was a timinimg chain, balance shaft chain....basically all my belts and chains...problem. That they need to be replaced. I was not having this problem before the waterpump replacement. For nearly $1600. Does this seem to make sense? I have a trust issue with dealerships. Appreciate your help
bevmak91 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Tags
balance shaft , timing chain , waterpump

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome