Slow Start and Fuel Smell - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 1Likes
  • 1 Post By esox07
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-01-2017, 09:17 PM Thread Starter
Forum Regular
 
Join Date: Dec 2014
Location: C. Wisconsin
Posts: 64
Slow Start and Fuel Smell

OK, my daughter seems to think I am responsible for everything that goes wrong with her Cobalt. She calls me an tells me that when she tries to start it it, it won't start right off. It either takes a few seconds of turning over before it starts or she has to stop and try to restart it and it fires up fine. She also says that she can smell gas.

I am thinking there might be a weak fuel pump or maybe a leak in the fuel line. If the fuel line is leaking, would that cause the car to lose fuel pressure between starts and thus make it take a bit longer for the fuel pump to build pressure when you go to start it after it has sat for a while? It seems to run fine after it starts.

Any help and thoughts would be great. She (nor I) have bunch of money to throw at it.
Thanks.

2007, 2dr, 2.2L if that makes a difference. The car has about 170,000 on it.
esox07 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-03-2017, 05:55 PM
Prospect
 
Join Date: Mar 2017
Location: Sacramento, CA
Posts: 20
I had my fuel pump go out but did not have a fuel leak. I've seen in other posts it's common for corrosion to develop on the drivers side in front of the rear tire. Maybe look there first? Could just be corrosion or an o-ring on a fuel line connection causing a leak.
Robert Moitoza is offline  
post #3 of 7 (permalink) Old 05-03-2017, 07:04 PM Thread Starter
Forum Regular
 
Join Date: Dec 2014
Location: C. Wisconsin
Posts: 64
Thanks for the reply. I checked it out and yes, the leak is just below the rear seat on the drivers side. It looks like it is at those rubber brackets just before it goes up over the wheel well. It is leaking bad when the truck is running and for a while afterwards. I think the leak is causing the slow start problem as well since it is allowing the fuel pressure to dissipate as it leaks and then it takes a couple seconds with the key in the Ignition position to get the fuel pump to repressurize the system.

I am taking it to a mechanic on Monday. Hopefully he won't have to replace the entire line and/or drop the tank.
esox07 is offline  
 
post #4 of 7 (permalink) Old 05-03-2017, 09:27 PM
Initiate
 
WICobaltSS's Avatar
 
Join Date: Apr 2016
Location: Wisconsin
Posts: 50
Hey esox07,
Yeah, my daughter's Saturn Ion had that too, right in front of the driver's side rear wheel well. Caused it to start hard. It leaked until the fuel pressure was relieved then it'd stop until the car was started again. I ended up cutting that section out all the way to the fuel filter and used compression fittings to splice it in. Not a hard job, just time consuming bending the new line to fit like the old line.


2006 Cobalt SS/NA
WICobaltSS is offline  
post #5 of 7 (permalink) Old 05-04-2017, 07:51 AM Thread Starter
Forum Regular
 
Join Date: Dec 2014
Location: C. Wisconsin
Posts: 64
Sounds just like the problem on my daughter's car. The problem is, I am leery with cutting fuel lines and having to do it on my back with the car jacked up is not optimal. Also, if the problem is worse than just a small leak, then I don't want to get halfway into it and have to call for help. I am taking it to the mechanic and let him do it. The guy I know does work part time and is very reasonably priced for labor. He has all the tools and knowledge.
Speaking of the fuel filter, I will probably have him swap that out at the same time....thanks.
I will try to remember to report back next week on the outcome. I am taking it in Monday.
esox07 is offline  
post #6 of 7 (permalink) Old 05-04-2017, 09:17 AM
Forum Regular
 
Join Date: Jun 2010
Posts: 142
Check with GM...there is a recall for faulty fuel pumps and corrosion...your vehicle might be covered !
fl1000 is offline  
post #7 of 7 (permalink) Old 05-04-2017, 11:40 AM Thread Starter
Forum Regular
 
Join Date: Dec 2014
Location: C. Wisconsin
Posts: 64
Nope, I don't see any recalls on her car. Thanks, good tip though.
Robert Moitoza likes this.
esox07 is offline  
Sponsored Links
Advertisement
 
Closed Thread




Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome