Transmission/Throttle Nightmare - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-19-2017, 11:58 AM Thread Starter
Newcomer
 
Join Date: Jun 2017
Posts: 3
Transmission/Throttle Nightmare

I'm at my wit's end so I'm hoping for some help here.

05 Cobalt with 130,000 miles on it. Replacement throttle body and system reflash in October of 2016 for the stalling issue so many Cobalts have.

Recent replacement of cracked coolant tank and thermostat four weeks ago.

Rough idle led me to replace the transmission two weeks ago. Defective rings had to be replaced after oil began leaking two days after transmission replacement. No more oil leaks.

Two days ago it began surging when shifting gear and a check engine light came on.

Took it to a dealership thinking they could diagnose a sensor/computer issue as the transmission has been looked at and replaced so recently. They're telling me it's kicking back error codes for throttle body and transmission. Picking it up to return to my mechanic as both repairs are under warranty.

I am losing my mind and commute to work so no carpool or days off are an option. I see a lot of results for sensor and connector issues, has anyone seen this lead to misdiagnosed error codes, etc?
Lind Tailor is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-19-2017, 12:55 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Can you list the codes?

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #3 of 3 (permalink) Old 06-22-2017, 12:36 PM Thread Starter
Newcomer
 
Join Date: Jun 2017
Posts: 3
Update: Adjusting the wire harness on the transmission cleared both codes. Waiting to see if the check engine light pops back on but so far so good. The throttle body code was P2119.
Lind Tailor is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome