Ugh...more Issues - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-19-2017, 09:26 PM Thread Starter
Prospect
 
Join Date: Jul 2017
Posts: 30
Ugh...more Issues

So long story short I drop the car off running at the dealership to get the recalls for the ignition switch done. (I couldn't remove the key). Now the car will not crank. Yes I know I should make them fix it but we are far beyond that point. The technician is pointing towards the fuse box. What I noticed tonight: 12v at the jump post on the fuse box. No lights on the dash except for the security tell tale (No e brake light, no seat belt light, no CEL). However the gauges light up and thr odometer comes on. It does seem as though many modules are missing power. Any ideas at all?
Charlie Gates is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-20-2017, 07:41 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Check all the fuses and the big one in the trunk.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #3 of 3 (permalink) Old 08-20-2017, 08:25 AM Thread Starter
Prospect
 
Join Date: Jul 2017
Posts: 30
I did. They are all fine except for a large one, for the cooling fans. Right above the run/crank fuse. Obviously there are plenty that aren't getting power, but not blown.
Charlie Gates is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome