2009 Chevy Cobalt Issues - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 1Likes
  • 1 Post By Coby7
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-30-2017, 07:34 AM Thread Starter
Newcomer
 
Join Date: Aug 2017
Posts: 1
2009 Chevy Cobalt Issues

Someone please help! Have a 2009 Chevy Cobalt. While driving the RPM's started Fluttering all over the place from 4k to 0. Then it dropped to 0 and stayed there. Service traction popped up. The engine didn't cut out. It stayed in low gear. While sitting in driveway, put car in park then neutral and then reverse it was shifting hard. Put car back in park and shut off. When started back up the code went away and shifting was better. Took car to a friend, who pulled and cleared the codes. Car has ran fine for @ 200 miles. Last night it started doing the same as above again. Any thoughts?
Janeanc is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-30-2017, 06:02 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
What are the codes? if you have a communication just pull the 2 blue gray connectors from the BCM and re-seat a few times to clean possible corrosion.



---------- Post added at 10:02 PM ---------- Previous post was at 09:57 PM ----------

If that doesn't help try replacing the ECM/TCM fuse top left corner red 10 amp fuse.
Parthros likes this.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly

Last edited by Coby7; 08-30-2017 at 06:01 PM.
Coby7 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome