Cruise Control - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 1Likes
  • 1 Post By Coby7
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 01-29-2018, 05:26 PM Thread Starter
Newcomer
 
Join Date: Jan 2018
Posts: 8
Cruise Control

Can anyone give me some guidance? The cruise control in my cobalt lights up at the steering wheel but doesnít set when I press the button. I am lost on the cruise control and honestly donít know where to begin. Any info will be greatly appreciated. Thanks in advance!
Mark Calvert is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 01-29-2018, 05:38 PM
Forum Regular
 
rooster4321's Avatar
 
Join Date: Oct 2015
Posts: 117
I have an 06 did the same thing took the button out of the right side of the steering wheel got a new one from RockAuto about 12 bucks
rooster4321 is offline  
post #3 of 10 (permalink) Old 01-29-2018, 06:47 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Check you high brake light to see if it works!

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
 
post #4 of 10 (permalink) Old 01-29-2018, 07:38 PM Thread Starter
Newcomer
 
Join Date: Jan 2018
Posts: 8
Coby7 you nailed it!! Thanks for all of your help and everyone else that pitched in. You guys are great. Cruise works!
Mark Calvert is offline  
post #5 of 10 (permalink) Old 01-30-2018, 03:25 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Burnt bulbs or something else?

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #6 of 10 (permalink) Old 01-30-2018, 09:50 AM Thread Starter
Newcomer
 
Join Date: Jan 2018
Posts: 8
The bulbs were all burnt out. Replaced them and the cruise worked for one trip to work this morning. Now it wonít work any longer. Bulbs still working. Do you happen to know if the radio missing could cause this issue? Steering wheel airbag has been deployed as well and Iím sure that can have an affect on it. You wouldnít happen to know would you?
Mark Calvert is offline  
post #7 of 10 (permalink) Old 01-30-2018, 10:07 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
If the GMLan wire as been cut or damaged at the radio it could cause the signal to hang. This would be a dark green wire.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #8 of 10 (permalink) Old 01-30-2018, 10:31 AM Thread Starter
Newcomer
 
Join Date: Jan 2018
Posts: 8
What could I do to temporarily fix this until I get a stock radio put back into it? Ground it out?
Mark Calvert is offline  
post #9 of 10 (permalink) Old 01-30-2018, 02:40 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Let me see if I can find the schematic. You can't ground it out because then nothing will work.

---------- Post added at 06:40 PM ---------- Previous post was at 06:38 PM ----------

What year?
1966tbird likes this.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #10 of 10 (permalink) Old 02-03-2018, 10:08 AM Thread Starter
Newcomer
 
Join Date: Jan 2018
Posts: 8
Very sorry about not getting back to you. Itís a 2010. I did pull the battery and reset and itís working again. Not sure if when they cut the wires they caused the BCM to wig out or what but as of right now it is working. Now. Final problem is the airbag. Any ideas on how to reset the clock spring for the steering wheel airbag? Btw, I got a stock radio coming I. Today so I can finally have some tunes!
Mark Calvert is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome