P0303, P0304 P0300 moving misfires? - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 02-09-2018, 07:14 PM Thread Starter
Contributor
 
FloodKillaz's Avatar
 
Join Date: Mar 2014
Location: Lancaster, Pa
Posts: 278
Garage
P0303, P0304 P0300 moving misfires?

I'm ready to light this car on fire. Started off with a P0300, then went to 0303,0304 and after repairs 0303. I've replaced the coils, plugs, and ran some seafoam through the tank. I can feel the misfire on idle but not much else. Also seeing a little less MPG. Was going to change the fuel filter, but it turns out that mine is in the tank. Car is a 2010 LT with 49k miles. Any suggestions?

2010 Cobalt LT K&N TYPHOON INTAKE
2004 Cavalier LS clone
2003 Saturn L200 Fully loaded-Sold
1987 Toyota Celica
FloodKillaz is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 02-16-2018, 02:55 AM Thread Starter
Contributor
 
FloodKillaz's Avatar
 
Join Date: Mar 2014
Location: Lancaster, Pa
Posts: 278
Garage
Also replaced all 4 injectors. Still throwing p0304 for cyl 4.

2010 Cobalt LT K&N TYPHOON INTAKE
2004 Cavalier LS clone
2003 Saturn L200 Fully loaded-Sold
1987 Toyota Celica
FloodKillaz is offline  
post #3 of 10 (permalink) Old 02-16-2018, 03:04 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,819
Garage
What kind of plugs did you put in? Did you check the misfire count to make sure you actually had a misfire. You may have a bad HO causing the ECM to trim too much fuel. Make sure your intake isn't leaking.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
 
post #4 of 10 (permalink) Old 02-16-2018, 03:10 AM Thread Starter
Contributor
 
FloodKillaz's Avatar
 
Join Date: Mar 2014
Location: Lancaster, Pa
Posts: 278
Garage
I replaced them in the summer with double iridium. I figured they were fouled for some reason so I had enough for double plat this time. I still have the iridiums but get funny about putting used plugs back in. All my scanner said was p0300 at first, then started picking specific cylinders. Intake clamp is tight on both ends. Wouldn't a bad 02 have it's own trouble code?

2010 Cobalt LT K&N TYPHOON INTAKE
2004 Cavalier LS clone
2003 Saturn L200 Fully loaded-Sold
1987 Toyota Celica
FloodKillaz is offline  
post #5 of 10 (permalink) Old 02-16-2018, 03:17 AM Thread Starter
Contributor
 
FloodKillaz's Avatar
 
Join Date: Mar 2014
Location: Lancaster, Pa
Posts: 278
Garage
Also need to add that my car has no fuel filter and SAI. I think it's Cali emissions, but had stickers for both under the hood.

2010 Cobalt LT K&N TYPHOON INTAKE
2004 Cavalier LS clone
2003 Saturn L200 Fully loaded-Sold
1987 Toyota Celica
FloodKillaz is offline  
post #6 of 10 (permalink) Old 02-16-2018, 06:01 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,819
Garage
Quote:
Originally Posted by FloodKillaz View Post
Wouldn't a bad 02 have it's own trouble code?
When it fails completely yes, but while it's in limbo and on the edge of it's limit they cause all kinds of funny codes including lean codes and the infamous P0303

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #7 of 10 (permalink) Old 02-16-2018, 09:14 AM Thread Starter
Contributor
 
FloodKillaz's Avatar
 
Join Date: Mar 2014
Location: Lancaster, Pa
Posts: 278
Garage
Unhappy

I ordered both O2 sensors and will be installing them tomorrow. Will report back with my findings. Thank you for the help. I am pretty nervous, ive had this car for 4 years, im so close to paying it off. People on the FB cobalt group im on keep saying its a bad head and valves etc. With only 49k miles i dont think that should be a big concern yet. If the 02 sensors dont help then i will throw a compression tester on and see whats up. After new coils, injectors, plugs and soon 02 sensors im running out of hope.

2010 Cobalt LT K&N TYPHOON INTAKE
2004 Cavalier LS clone
2003 Saturn L200 Fully loaded-Sold
1987 Toyota Celica
FloodKillaz is offline  
post #8 of 10 (permalink) Old 02-16-2018, 10:33 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,819
Garage
I imagine you have already cleaned the MAF and throttle body.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #9 of 10 (permalink) Old 05-28-2018, 12:30 PM
Contributor
 
Join Date: Jul 2016
Posts: 443
I am guessing without the follow up post that P0300 grimlin left for a while.

BC
1966tbird is offline  
post #10 of 10 (permalink) Old 05-28-2018, 02:58 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,819
Garage
It would appear so, was probably the HOs going out of acceptable range.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome