No Power & Speedometer Not Working Properly - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-22-2018, 07:20 AM Thread Starter
Prospect
 
Join Date: Dec 2014
Posts: 10
No Power & Speedometer Not Working Properly

Hey everyone, I am wondering if anyone else here has had the issue of their cobalt having the speedometer not work when driving under 20km and having low engine power when you step on the gas? The tachometer revs high but the car takes awhile to accelerate. After a bit the car seems to get power and the speedometer starts to work.

I brought the car to the mechanic and they say they tore it down and could not find the issue. They think it might be a sensor. The car is a 2005 model.

Has anyone here had something similar happen? Any input would be greatly appreciated.
Thanks

Last edited by sean99; 02-22-2018 at 07:28 AM.
sean99 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome