P0171 Lean Code - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Problems and Service Talk about any mechanical problems you are having

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-09-2018, 11:34 AM Thread Starter
Prospect
 
Join Date: Nov 2017
Location: Mesa, Arizona
Posts: 33
P0171 Lean Code

so a few months ago my start and fuel pump had went out, so i had them replaced. after getting my car back from the shop i got the P0171 Code not to long after and they would just tell me the code and that it was running lean. i was going to pay them to have them keep working on it if they werent going to tell me what the problem was. Since i had those replaced i have replaced my fuel filter, my injectors, my MAF sensor, i had a crack in my exhaust manifold so i replaced with headers, i have replaced the O2 sensor, i kept getting the lean code.

I had an issue with the nipple to the hose on my original air intake. so i replaced with one off of Ebay that looks just like a Injen intake, but i still am getting this code. I have disconnected the positive side of the battery for more than an hour (i know only 15 mins needed but i just left it be because i was busy).

the other day when i was pulling into a parking spot the CEL shut off after running kind of hard for a second. and then on my drive home the CEL came back on.

What do you guys think it is.
BoBotheBarbaria is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome