JL Audio E 1200 Mono Amp - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
For Sale (Car Related Only) Post your car-related parts you have for sale!

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 11-14-2009, 11:34 AM Thread Starter
Cobalt Master
 
Join Date: Sep 2008
Location: Albany NY
Posts: 1,969
JL Audio E 1200 Mono Amp

JL E1200 mono block amp
i have no clue if this works but it was taken out of my sisters car along with the subs that this amp was powered to. i put the subs in my car and they work fine. So if the subs work the amp has to work. But i do not 100% know if the amp still works or not and have no way to test it.

used but cosmetically it looks good.

pm me if interested

i want around 100-125 for it plus shipping
cobalt08ls is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 11-14-2009, 01:26 PM
Cobalt Specialist


 
Nosfuratu9's Avatar
 
Join Date: Apr 2009
Location: Tx
Posts: 1,442
Garage
Nosfuratu9 is offline  
post #3 of 10 (permalink) Old 11-14-2009, 01:44 PM Thread Starter
Cobalt Master
 
Join Date: Sep 2008
Location: Albany NY
Posts: 1,969
here are some pics




i have no clue if it works
but i want to assume it works because it was connected to the subs that are currently in my trunk
and i have no clue how to test it

Last edited by cobalt08ls; 11-14-2009 at 01:49 PM.
cobalt08ls is offline  
 
post #4 of 10 (permalink) Old 11-16-2009, 11:51 AM Thread Starter
Cobalt Master
 
Join Date: Sep 2008
Location: Albany NY
Posts: 1,969
cobalt08ls is offline  
post #5 of 10 (permalink) Old 11-16-2009, 11:54 AM
Super Moderator
YourCobalt of the Month Winner


 
Beamer's Avatar
 
Join Date: Jan 2008
Location: Charlotte, NC
Posts: 3,783
Garage
Send a message via AIM to Beamer Send a message via Yahoo to Beamer
would like a new or better amp but I am not paying for something that may or may not work lol. Bumpage.

My Gone But Not Forgotten Cobalt(s) Show off

2015 Fiat 500 Abarth | 2016 International Durastar

Check out my Youtube page
Beamer is offline  
post #6 of 10 (permalink) Old 11-16-2009, 11:55 AM Thread Starter
Cobalt Master
 
Join Date: Sep 2008
Location: Albany NY
Posts: 1,969
i wish i knew how to test it lol
any way to do it with out ripping apart the wires on my amp in my car?
cobalt08ls is offline  
post #7 of 10 (permalink) Old 11-16-2009, 11:56 AM
Newcomer
 
xxusda69xx's Avatar
 
Join Date: Oct 2009
Posts: 22
hook the amp up in you car to test

it prob would sell faster if it for sure worked
xxusda69xx is offline  
post #8 of 10 (permalink) Old 11-16-2009, 12:00 PM Thread Starter
Cobalt Master
 
Join Date: Sep 2008
Location: Albany NY
Posts: 1,969
any other ways to test it?
im not messing around with the wires back there because if i mess something up or dont remember where something plugs in im not paying to get it fixed

i know someone who works at bestbuy who may be able to test it
cobalt08ls is offline  
post #9 of 10 (permalink) Old 11-16-2009, 12:06 PM
Super Moderator
YourCobalt of the Month Winner


 
Beamer's Avatar
 
Join Date: Jan 2008
Location: Charlotte, NC
Posts: 3,783
Garage
Send a message via AIM to Beamer Send a message via Yahoo to Beamer
chances are its working fine though

My Gone But Not Forgotten Cobalt(s) Show off

2015 Fiat 500 Abarth | 2016 International Durastar

Check out my Youtube page
Beamer is offline  
post #10 of 10 (permalink) Old 11-16-2009, 12:08 PM Thread Starter
Cobalt Master
 
Join Date: Sep 2008
Location: Albany NY
Posts: 1,969
yes.
i would put money on it it works
the subs work fine. and she took everything out of her other car when she wrecked it because she wanted to keep it.
the subs sat in my garage for about at least 4 years tops. along with the amp so i dusted off the subs and powered em to a new amp i bought not even knowing if they worked. and everything works fine. so if the subs work the amp works
cobalt08ls is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome