2009 Cobalt LT with annoying and seemingly untraceable vibration in front end above 4 - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Suspension/Wheels/Brakes/Tires Talk about Chevy Cobalt Suspension, Brakes, Wheels, and Tires here
Sponsored by:

 7Likes
  • 1 Post By ewelcris
  • 1 Post By ewelcris
  • 1 Post By ewelcris
  • 1 Post By 1966tbird
  • 1 Post By ewelcris
  • 1 Post By ewelcris
  • 1 Post By ewelcris
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 10-08-2018, 12:47 PM Thread Starter
Newcomer
 
Join Date: Oct 2018
Posts: 8
2009 Cobalt LT with annoying and seemingly untraceable vibration in front end above 4

Hello newbee here, just snagged a 2009 Cobalt LT dirt cheap. Has a vibration in the front end I just can't seem to track down and fix... In the past 3 days I have replaced tires hubs, tie rod ends, control arms, and had it aligned, but just cant seem to catch it, I have been told the steering column, but there is no undue play, or and suspect behavior there except the vibration... Please help.
ewelcris is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 10-08-2018, 02:29 PM
Expert
 
Parthros's Avatar
 
Join Date: May 2015
Location: Oklahoma
Posts: 945
Garage
Since you've already replaced just about everything else, have you checked the dampers & springs? Could just be that the struts are shot, especially if it's a non-ACDelco strut. Aftermarket struts & shocks have been known to prematurely fail.


Quote:
Originally Posted by Plain Jane View Post
Believe me, these cars have a habit of growing on their owners. Your feelings will only strengthen over time...
Parthros is offline  
post #3 of 9 (permalink) Old 10-09-2018, 12:18 AM Thread Starter
Newcomer
 
Join Date: Oct 2018
Posts: 8
No, I have not. I intend to change shock/struts, as well as the bar bushings. That's my next step, but, as you can imagine, my first 3 days with this car have been an expensive three days lol.
Parthros likes this.
ewelcris is offline  
 
post #4 of 9 (permalink) Old 10-09-2018, 12:48 AM Thread Starter
Newcomer
 
Join Date: Oct 2018
Posts: 8
Also, just found out the previous owner skidded into a guardrail... Just hard enough to break the headlight and bracket, wondering if maybe she tapped it just right to shove a tie rod into the rack and damage it? No play or OBVIOUS signs of damage in it though...
Parthros likes this.
ewelcris is offline  
post #5 of 9 (permalink) Old 10-09-2018, 01:47 AM Thread Starter
Newcomer
 
Join Date: Oct 2018
Posts: 8
So, today I drove the Cobalt instead of the Sequoia to work, first REAL milage I've put on it, drive didn't allow for any speed above 55mph, but the car despite the vibration surprised me at how well it handled through mountain curves, vibration starts at 45, and seems worse at a constant speed, and is felt even in curves (noticed some said there's went away in curves/turns) also... Turn signals won't shut off on their own, but the wheel "clicks" to shut off went turning even when the blinker isn't on......?
Parthros likes this.
ewelcris is offline  
post #6 of 9 (permalink) Old 10-09-2018, 07:50 PM
Contributor
 
Join Date: Jul 2016
Posts: 458
You might want to try and move the tires from the front to the back. Either you may have a wheel that is still a bit out of balance or it might be bent.
On your turn signal, there are posts here from Coby7 with images on how to fix it your self. Worst case is about $25 to replace the entire assembly with brand new turn signal arm.

By the way, what type and brand of tires did you get and from what shop?
Parthros likes this.

BC

Last edited by 1966tbird; 10-13-2018 at 11:41 PM.
1966tbird is offline  
post #7 of 9 (permalink) Old 10-10-2018, 04:31 PM Thread Starter
Newcomer
 
Join Date: Oct 2018
Posts: 8
Today I changed intake and exhaust actuators, and while I had the plastic cover off, I reached down and gave the halfshaft a good tug, and behold, there is slop in it at the transaxle. I have rotated my new Goodyears back and forth and all around with there now 50 miles on them lol My very reputable local tire shop and all their fancy gizmos mounted them for me and checked my alignment, and even freely recheck everything again for me.... I'm HOPING that's it... All that's left is to replace the rack... Which seems tight and true.
Parthros likes this.
ewelcris is offline  
post #8 of 9 (permalink) Old 10-10-2018, 04:32 PM Thread Starter
Newcomer
 
Join Date: Oct 2018
Posts: 8
Thanks 1966tbird, I'll check it out.
Parthros likes this.
ewelcris is offline  
post #9 of 9 (permalink) Old 10-10-2018, 04:40 PM Thread Starter
Newcomer
 
Join Date: Oct 2018
Posts: 8
Should be able to order my new shafts (may as well do both) next week, I'll let y'all know what happens. Literally other than the rack that will be the whole front end from bushings to tires replaced with NEW parts... Also, I order my parts based on reviews VS $$, so luckily I haven't had to replace many a second time on either of my vehicles. *knock on wood*. Also, thanks parthos for your input as well.
Parthros likes this.
ewelcris is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome