Strange Sounds in Front End. - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Suspension/Wheels/Brakes/Tires Talk about Chevy Cobalt Suspension, Brakes, Wheels, and Tires here
Sponsored by:

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 12-15-2010, 11:41 AM Thread Starter
Forum Regular
 
baines888's Avatar
 
Join Date: Jun 2010
Location: maine
Posts: 179
Garage
Strange Sounds in Front End.

I have loud smashes when i go over small bumps in the front passenger, and now there's a loud squeak along with the clanks. It is cold and winter here, so is it that my stock shocks are junk and freezing? on another thread everyone was saying our control arms and bushings where junk...so would that be the cause of the clunking?


help!

baines888 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 12-15-2010, 01:23 PM
Newcomer
 
Join Date: Dec 2010
Posts: 22
Well I don't have an answer but just to say that my shocks make some noise going over little bumps too.
Kind of like little pops and rattles. The roads where I am are complete cra* anyways. I think my shocks have taken a bit of a beating.
Best thing is to get it checked out if your still under warranty
frankb89 is offline  
post #3 of 10 (permalink) Old 12-15-2010, 07:12 PM
Cobalt Master
 
padlock's Avatar
 
Join Date: Feb 2010
Location: Wisconsin
Posts: 1,545
Garage
its probably normal! its a cobalt

padlock is offline  
 
post #4 of 10 (permalink) Old 12-15-2010, 07:14 PM
Forum God


 
BlackARCA06's Avatar
 
Join Date: Sep 2009
Location: Ohio
Posts: 2,724
I just ignore it, I got a brand new front suspension in April, and its already making noises.

2006 Cobalt: Bolt On's
BlackARCA06 is offline  
post #5 of 10 (permalink) Old 12-15-2010, 07:26 PM
YourCobalt of the Month WinnerVeteran


 
Foximus's Avatar
 
Join Date: Nov 2009
Location: Pittsburgh, PA
Posts: 667
Garage
Send a message via AIM to Foximus Send a message via MSN to Foximus Send a message via Yahoo to Foximus Send a message via Skype™ to Foximus
do you hear it when you accellerate? When my control arm bushings failed i would hear a loud creaking noise everytime i accellerated


Flight Of The Phoenix
Asylum Custom Interiors - Axcelerated Motorsports - TBI Fabrication
Foximus is offline  
post #6 of 10 (permalink) Old 12-16-2010, 12:55 AM
Cornier Than Ethanol
YourCobalt.com Premium Member


 
YellowSS06's Avatar
 
Join Date: Mar 2010
Location: Decatur, IL
Posts: 866
Garage
Mine used to do that on speed bumps and stuff in the winter. I'd say it's normal.


YellowSS06 is offline  
post #7 of 10 (permalink) Old 12-16-2010, 01:43 AM
Forum God


 
09-Cobalt-lt's Avatar
 
Join Date: Aug 2009
Location: North Vancouver, B.C.
Posts: 2,625
I have that since I lowered my car. it's something in the steering column
09-Cobalt-lt is offline  
post #8 of 10 (permalink) Old 12-16-2010, 10:14 PM
Veteran
 
Join Date: Dec 2004
Posts: 703
My steering feels like ass , the car rides really rough and clanks over bumps. Normal for this car to a point but now its so bad I'm bringing it in on Tuesday.
My guess is lower control arms (I will go for the FE5 ones for my LT if its bad) or tie rod ends.
steve333 is offline  
post #9 of 10 (permalink) Old 12-17-2010, 12:34 AM
YourCobalt of the Month WinnerCobalt Master


 
ff_drift_lol's Avatar
 
Join Date: Nov 2009
Location: lawn guyland
Posts: 1,890
i think it's your sway bar end links, control arm bushings or strut top hats. could also be a dry rotted spring perch, ball joint, steering intermediate shaft, all of the above, who knows. get some monroe's or something.

ff_drift_lol is offline  
post #10 of 10 (permalink) Old 12-17-2010, 07:41 AM
Veteran
 
Join Date: Dec 2004
Posts: 703
Holy crap, if its all that than time for a new car!
steve333 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome