Suspension Grinding Help - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Suspension/Wheels/Brakes/Tires Talk about Chevy Cobalt Suspension, Brakes, Wheels, and Tires here
Sponsored by:

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-09-2011, 03:30 PM Thread Starter
Forum Regular
 
nerdmanpap's Avatar
 
Join Date: Jan 2010
Posts: 197
Garage
Suspension Grinding Help

My front passenger side suspension grinds something awful on cold days when being driven for the first time for the day.

Any time the suspension travels more than 1.5 to 2" i'll get an awful grinding noise which I'm thinking is probably the strut.

After 20 miles or so the grinding will go away, but its awfully concerning to be having any suspension issues like this after only 12,900 miles. I'm not lowered, and my wheels are perfectly aligned.

any ideas on what it could be? or anything that I could look for to point out to the dealership to try and get it replaced? I've taken it in twice but once I get to the dealers it wont be grinding anymore. I've even left it overnight but they claimed it didnt make a sound for them at all

nerdmanpap is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-09-2011, 03:50 PM
YourCobalt of the Quarter Winner
YourCobalt of the Month Winner


 
BankerBalt's Avatar
 
Join Date: Oct 2010
Location: Eagan MN
Posts: 4,647
Garage
is it a kind of squeak noise or is it a grinding sound? because mine squeaks a bit if i go over a bump when it's cold too. i don't think that's anything too out of the ordinary when it's colder than all hell outside. but greasing points might be something to think about too.

Forged L61 BW S252 Turbocharged Showoff Thread
BankerBalt is offline  
post #3 of 5 (permalink) Old 01-09-2011, 05:15 PM Thread Starter
Forum Regular
 
nerdmanpap's Avatar
 
Join Date: Jan 2010
Posts: 197
Garage
i wish it was a squeak but it sounds like more of a grinding noise. You could classify it as a severely rough squeal, but I wouldn't say its a squeak at all. I'm thinking it has to be the front strut on the passenger side, maybe a seal is going, or has trouble allowing movement when cold

I've looked at the suspension and haven't really found any points to grease. any suggestions?

nerdmanpap is offline  
 
post #4 of 5 (permalink) Old 01-09-2011, 05:19 PM
XFE
Wootsauce!
Staff Alumni
YourCobalt.com Premium Member


 
Join Date: Oct 2008
Location: Pittsburgh, PA
Posts: 8,593
Send a message via AIM to XFE
Quote:
Originally Posted by nerdmanpap View Post
haven't really found any points to grease. any suggestions?
Factory suspensions components = There are no grease points.


As far as your "noise"....take a look at your Control arm bushings. They have been known to come out of the metal sleeves.

Also, you are under warranty. Just take it in.

---------- Post added at 07:19 PM ---------- Previous post was at 07:17 PM ----------

I had my steering rack and passenger side Control arm replaced at around 25,000 under warranty. No Charge. And a loaner car! Ha!

Just have them look at it...for real.




XFE is offline  
post #5 of 5 (permalink) Old 01-09-2011, 05:49 PM Thread Starter
Forum Regular
 
nerdmanpap's Avatar
 
Join Date: Jan 2010
Posts: 197
Garage
Quote:
Originally Posted by XFE View Post
Factory suspensions components = There are no grease points.


As far as your "noise"....take a look at your Control arm bushings. They have been known to come out of the metal sleeves.

Also, you are under warranty. Just take it in.

---------- Post added at 07:19 PM ---------- Previous post was at 07:17 PM ----------

I had my steering rack and passenger side Control arm replaced at around 25,000 under warranty. No Charge. And a loaner car! Ha!

Just have them look at it...for real.
I've taken it in twice now and they've sent me packing without fixing anything. Perhaps its time to try another dealership. I'll also take a look at the control arm bushings and see if i can spot any potential problems

nerdmanpap is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome