Vibration at 90km/hr and Higher - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Suspension/Wheels/Brakes/Tires Talk about Chevy Cobalt Suspension, Brakes, Wheels, and Tires here
Sponsored by:

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-12-2011, 04:34 PM Thread Starter
Forum Regular
 
barrett's Avatar
 
Join Date: Sep 2010
Location: St. John's, Newfoundland, Canada
Posts: 90
Garage
Vibration at 90km/hr and Higher

I have a 2010 2.2L and when I drive on the highway I begin to feel a vibration at about 80-90km/hr. It's hard to explain but it kind of vibrates three time, pause for a second, vibrates three times, pause for a second.. and so on... it doesn't vibrate with the rotation of the wheels or anything like that so I don't know what it could be. I notice it in the steering wheel.

Also when I brake at higher speeds my steering wheel shakes... rotors??

---------- Post added at 08:04 PM ---------- Previous post was at 08:01 PM ----------

oh, and I have H&R sport springs... but thats only an inch drop


2010 Cobalt LS XFE
GMPP Intake - H&R Sport Springs - Morimoto MH1 Retrofitted Headlights - Alpine IDA x305 Head Unit - MPx Shorty Antenna
barrett is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-12-2011, 11:29 PM
Newcomer
 
Join Date: Mar 2011
Posts: 33
Get the tires balanced and have the tech check for proper bead seat on the tires. If your running low pros it common for that to be missed during install, or you may have kicked a few weights.
Rico07sssc is offline  
post #3 of 4 (permalink) Old 08-13-2011, 06:19 AM
Forum God


 
BboyTaktix's Avatar
 
Join Date: Oct 2009
Location: CANADA! Montreal (party city), Quebec
Posts: 3,229
As for the braking vibrations, cobalts have a tendency to warp rotors fairly easily. I believe mine might be a bit warped too. Might want to check that out as well.

BboyTaktix
- 2011 Plasma Blue pearl WRX STI sedan
- SOLD -S256 TURBO 2.2 -SS/TC body, SS/Tc shocks/struts, B&G springs, 17"mags, TRS FX-R retrofits (50W/6000k)
BboyTaktix is offline  
 
post #4 of 4 (permalink) Old 08-13-2011, 06:44 AM Thread Starter
Forum Regular
 
barrett's Avatar
 
Join Date: Sep 2010
Location: St. John's, Newfoundland, Canada
Posts: 90
Garage
Quote:
Originally Posted by Rico07sssc View Post
Get the tires balanced and have the tech check for proper bead seat on the tires. If your running low pros it common for that to be missed during install, or you may have kicked a few weights.
that seems to be what everyone is telling me. I dont have low pros though, im just runnin 15's right now so id say they're just off balance

thanks for the help


2010 Cobalt LS XFE
GMPP Intake - H&R Sport Springs - Morimoto MH1 Retrofitted Headlights - Alpine IDA x305 Head Unit - MPx Shorty Antenna
barrett is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome