Coilovers rear squeeking - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Suspension/Wheels/Brakes/Tires Talk about Chevy Cobalt Suspension, Brakes, Wheels, and Tires here
Sponsored by:

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-18-2014, 03:50 PM Thread Starter
Forum Regular
 
SilverBullett's Avatar
 
Join Date: Feb 2013
Location: STL
Posts: 120
Garage
Coilovers rear squeeking

So basically my rear has been squeeking mainly at low speeds. Can't determine exactly where it is coming from. It may be the shock but I think it's the rubber mount thing (don't know what's it's actually called). I kept the stock ones and they were pretty wore out, going to the dealer tomorrow to see how many thousands of dollars they want for a little piece of rubber. Looking for input of what you think it is or if anyone has had this issue.


Sent from AutoGuide.com Free App
SilverBullett is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-18-2014, 03:54 PM
Cobalt Specialist
 
Dustinb855's Avatar
 
Join Date: Jun 2013
Location: Westminster, CO
Posts: 1,373
hmm weird because you just bought these coilovers right?
Dustinb855 is offline  
post #3 of 4 (permalink) Old 03-18-2014, 04:40 PM Thread Starter
Forum Regular
 
SilverBullett's Avatar
 
Join Date: Feb 2013
Location: STL
Posts: 120
Garage
yes they've been on for about 2 or 3 weeks. Im thinking it is just the rubber piece but it is only at low speeds. I've had people stand outside my car and they say they cant really hear it but when im in my car it sounds like its coming from inside the trunk so i think its coming from that top rubber mount.
SilverBullett is offline  
 
post #4 of 4 (permalink) Old 04-06-2014, 04:26 PM Thread Starter
Forum Regular
 
SilverBullett's Avatar
 
Join Date: Feb 2013
Location: STL
Posts: 120
Garage
The squeaking in the rear is becoming almost unbearable. I'm thinking it's the shocks. I don't think there blown, I haven't hit ANY bumps and if I did it was at about 4mph. Anyone have any ideas. I'm going to try and contact ksport tomorrow and see what they say.


Sent from AutoGuide.com Free App
SilverBullett is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome