ABS and Traction Control - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Suspension/Wheels/Brakes/Tires Talk about Chevy Cobalt Suspension, Brakes, Wheels, and Tires here
Sponsored by:

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 01-06-2015, 04:39 PM Thread Starter
Aja
Prospect
 
Join Date: Oct 2014
Location: Minnesota
Posts: 26
ABS and Traction Control

It's been around 0 here for the last week, adding wind chill around -20 or -30. I went to leave today and I almost couldn't get out of the driveway. I had the gas to the floor and it didn't do anything for a couple seconds. Turned off traction control and tried again, same thing but finally it got going and I managed to get out of the driveway. It felt like one of my wheels wasn't even turning. I tried to take a left and ended up doing a donut instead of turning the corner. Abs and traction lights were both on and then stayed on. Speedometer was acting funky too. Also shifting like crap.

I can hear a clunking sound continuously while I'm driving. At first sounding like the front end but now I think it's the back. My drivers side rear tire has been needing air in it about every three days.

After turning the car off and back on an hour later the lights were off. Clunking still going strong though. I have a few dtc codes and cel has been on for months now. The codes I know are P1174 and P2270. There are two more I don't remember right now, one was a body code that didn't have a description and some other P code.

The dealership here sucks and I know they are just going to dick me around cuz I am a woman.

Wheel speed sensor or camshaft actuators? I replaced both camshaft solenoids two months ago and that dtc code has not came back since then.
This is an 08 sport 2.4L btw.

Last edited by Aja; 01-06-2015 at 04:42 PM.
Aja is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 01-06-2015, 05:52 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Most dealers are really stealers.

My initial thoughts are that the 2 codes you have mention are actually byproducts of the real parasite problem. I don't want to be sexest here but are you handy around a car? I'm going to give you what UI think you should do in a few steps, if you don't feel comfortable, ask for help.

1. Disconnect negative of battery cable.
2. Remove BCM cover on passenger side console footwell.
3. Remove both blue and gray connectors from BCM.
4. Re-insert and disconnect a few times to clean contacts.
5. Close everything up and re-connect battery
6. Start car and come back here and tell me how your Cobalt is running.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #3 of 10 (permalink) Old 01-06-2015, 05:59 PM Thread Starter
Aja
Prospect
 
Join Date: Oct 2014
Location: Minnesota
Posts: 26
I reseated both those connectors and put dielectric grease on them a month ago when I had the tach reading 0 and torque says I had no fuel pressure.

I luckily know some things about cars and have the "bible" for my car that I got from a torrent. I will be replacing my flex pipe myself when I get the money for it. :D
Aja is offline  
 
post #4 of 10 (permalink) Old 01-06-2015, 06:12 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
Did you also swap fuse 26? often gets pitted and can cause your symptoms. But if all these fail your next problematic would be a wheel bearing not sending wheel speed to ECM causing havick amongst all CPU's. One way to check is to apply cruise, if it doesn't latch or if it latches and quickly aborts you probably have a bad wheel bearing. When a bearing goes bad enough it causes the reluctor ring to be askew from the WSS (Wheel Speed Sensor) causing all the symptoms you are having, also causing engine to go into possible limp mode, causing the codes that you see because you probably press harder on the pedal and injecting more fuel than the engine can burn. Causing in turn all these HO2 codes because you are running lean when the TPS is saying you should be running rich. Big mess in short. Anybody with a TechII or similar scanner will be able to tell you which wheel bearing is the culprit if this is the case. My guess front passenger side, but just and educated guess.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #5 of 10 (permalink) Old 01-06-2015, 07:00 PM Thread Starter
Aja
Prospect
 
Join Date: Oct 2014
Location: Minnesota
Posts: 26
I pulled every fuse and flipped them all. I actually used the cruise control today and it worked fine. I know the ho2 codes are because my flex pipe is cracked. Or is that not true?
Aja is offline  
post #6 of 10 (permalink) Old 01-07-2015, 04:14 AM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
That's quite possible too. Looks like you have some work ahead. One problem at a time.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #7 of 10 (permalink) Old 01-07-2015, 03:01 PM Thread Starter
Aja
Prospect
 
Join Date: Oct 2014
Location: Minnesota
Posts: 26
It also has no reading for the rear drivers wheel sometimes and then pops up the service tpms, but after a little bit the reading comes back. And it's a thud sound not clunking.

I guess I just need to know if I should be driving this or not.
Aja is offline  
post #8 of 10 (permalink) Old 01-07-2015, 03:14 PM
Super Moderator
YourCobalt.com Premium Member


 
Coby7's Avatar
 
Join Date: Oct 2011
Location: Magnetic Hill, New-Brunswick
Posts: 11,820
Garage
TPMS is just a sensor with a battery incorporated inside the sensor. They last between 5 and 7 years. I've already replaced one on my wife's 2008 G6. TPMS in no way endanger driveability. Wheel bearing on the otherhand should be looked at after your flex pipe or at the same time.

Every minute spent angry is a happy minute lost for ever and ever!!!
Drives 2016 Cocoa Buick Encore 1.4L Turbo auto KL4CJDSB2GB652675
Drives 2016 Sunset Orange Trax LT1 1.4L Turbo auto 3GNCJPSB8GL142716

Never drive faster than your guardian angel can fly
Coby7 is offline  
post #9 of 10 (permalink) Old 01-07-2015, 04:33 PM Thread Starter
Aja
Prospect
 
Join Date: Oct 2014
Location: Minnesota
Posts: 26
So I went to the dealership to see if someone could drive it or ride with me to see if it was safe. They are open until 8pm but at 5:30pm, the same guy that I had to talk to when I had the ignition recall done, said he was the only one working so no one could drive it. I described it to him and he said it sounded like wheel bearing and it was ok to drive.

I didn't believe him so I brought it to the dealer I bought it from and they were nice enough to have a guy that could ride with me. Then he put it on a hoist and my rear drivers tire has a HUGE flat spot where you can see a ton of threads. They said I'm lucky it didn't blow and obviously shouldn't drive it anywhere. Brakes are fine now but the caliper froze or something.

I took a pic but it's saved in wrong format so I can't upload it on here. So two new tires now yay.
Aja is offline  
post #10 of 10 (permalink) Old 01-07-2015, 07:43 PM Thread Starter
Aja
Prospect
 
Join Date: Oct 2014
Location: Minnesota
Posts: 26
But I also sent an email to the dealer I went to, Clements Chevrolet, and another to Chevy Customer Service about these events.

Hopefully I can get something close to a human response from one of them. I'm not holding my breath though.
Aja is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome