2010 Cobalt LT suspension issues - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Suspension/Wheels/Brakes/Tires Talk about Chevy Cobalt Suspension, Brakes, Wheels, and Tires here
Sponsored by:

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-14-2016, 09:57 PM Thread Starter
Newcomer
 
Join Date: Jan 2012
Posts: 2
2010 Cobalt LT suspension issues

Hello all,

So as you can see in the title, I've been having some other issues with my cobalt as well. I live in Iowa and we've been having some really unfortunate weather here and my poor cobalt has taken a beating because of it! I have the rattle that a lot of you seem to have but I've noticed a new sound as of last week and it's very unsettling. When I drive over large humps or potholes at low speeds I hear what sounds like a crunch coming from the suspension area on the front passenger side. To compare it, I'd say it sounds like there's a chunk of snow lodged in my wheel well, but there's not! I've taken the wheel off and looked around but I'm not really sure what to look for. Has anyone else ever had this issue?? Please help!!!

And just to confirm, that common "rattle" heard from the suspension at low speeds, that is the sway bar end links right? I've seen a couple people post about that being the issue but I've also seen some people saying it's the control arm bushing. I will replace both if needed I'm just not real sure how to narrow it down.

Any help is really appreciated. Thanks for taking time out of your day to help a fellow cobalt owner!
oFFLiNe YaH DiG is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-19-2016, 10:55 AM Thread Starter
Newcomer
 
Join Date: Jan 2012
Posts: 2
Alright guys, a little background on my Balt. 2010 LT with 110k miles. I pulled the front wheels off today cuz it was a little warmer out and tinkered around. There was no play at all in the end links. I couldn't really tell because of the Lighting but the control arm pancake bushings didn't look to be pushed out (I'm not sure how else to tell if they're bad but I'm sure they are). No play in the tires either. Struts looked good, rusty, but no breaks or leaks or anything. Only thing I noticed was the rack and pinion moved a bit, is that normal?
oFFLiNe YaH DiG is offline  
post #3 of 3 (permalink) Old 02-22-2016, 09:03 AM
Cobalt Specialist
 
Dustinb855's Avatar
 
Join Date: Jun 2013
Location: Westminster, CO
Posts: 1,373
Rack and pinion is ok to have a little movement as the car gets older as long as it's not a whole lot. Are u sure your lower control arm bushings aren't ripped or anything?

Showoff thread finally!!!! : )
https://www.yourcobalt.com/forums/veh...ustinb855.html

Quote:
Originally Posted by Coby7 View Post
WRX are as nice as they get.
Dustinb855 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome