Cobalt issue with speed sensor - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Transmission All about the Chevy Cobalt Transmission

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-17-2014, 03:51 PM Thread Starter
Newcomer
 
Join Date: Jun 2014
Posts: 4
Cobalt issue with speed sensor

I am wondering how to get the speed sensor out of the transmission. It is stuck...and my speedometer goes haywire so I have to clean/replace it. My cobalt is a 2.2 coupe 2005 model and its 5 speed

Last edited by banana_cobalt; 09-17-2014 at 03:57 PM.
banana_cobalt is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-17-2014, 03:59 PM
Staff Alumni
 
money_man's Avatar
 
Join Date: Mar 2012
Location: Halifax, N.S
Posts: 3,127
Oh hello there dear brother. First describe your problem to the gang, it may not even be a speed sensor


Sent from the sexy electrician

2009 Ford Escape Limited - 3.0L, 6 speed auto, 4x4, 25/33 city/hwy imp mpg.
2017 F150 XLT-XTR - 5.0L, 4x4, 3.55's, E-locker, xtr chrome package, fx4 off-road package.
20/25 imp mpg
money_man is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome