2007 Chevy Cobalt Transmission - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Transmission All about the Chevy Cobalt Transmission

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-22-2015, 08:36 PM Thread Starter
Prospect
 
Join Date: Jul 2015
Posts: 28
2007 Chevy Cobalt Transmission

HI, I have a 2007 Chevy Cobalt with an automatic transmission. The vehicle has about 70,000 miles on it. This has been a very good vehicle with no trouble until recently when I replaced the CV axle. While trying to remove the cv axle the entire axle came out of the transmission. I was told this would not create a problem however, just to be on the safe side I had a friend, who is a mechanic, stop by to help me complete the job. Everything seemed to go back together fine but now the car is making a roaring sound which seems to be coming from the transmission. Also since the axle has been replaced I have had to replace the speed sensor three times. When he installed the main axle I noticed the wire keeper was not on the end of the axle. I brought this to his attention and he said that it was probably still inside the transmission and would snap into place once the axle was installed. Since he is a mechanic I took his word and he completed the job. I do not know if the keeper was actually still in place or whether the axle locked into place when he installed it into the transmission. If the keeper that locks the main axle in place is not in place, would this cause the axle to have just enough play to scar the speed sensor causing it to malfunction? If not,does anyone have any idea what would cause this problem? I looked inside the transmission, through the hole where the speed sensor mounts, and seen what looks similar to a "flywheel" or "gear" which I assume feeds the speed sensor it's information but this "gear" keeps getting out of line just enough to scar the end of the speed sensor causing it to malfunction. When the speed sensor goes out the car will run about 30mph, top speed, although the speedometer will register between 80mph and 100mph. Any advice will be greatly appreciated. Thanks
Poppie51 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-25-2015, 10:37 AM
Forum Regular
 
Macky91's Avatar
 
Join Date: Jan 2013
Location: tulsa ok
Posts: 101
Garage
i would take it to a shop have them look into it
the CV axel swopp you did is a simple task.

CEEJBRO!!
email
[email protected]
Macky91 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome