2010 Cobalt trans problem - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Transmission All about the Chevy Cobalt Transmission

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-04-2016, 02:39 PM Thread Starter
Newcomer
 
Join Date: Jan 2016
Posts: 3
2010 Cobalt trans problem

I'm having seems to be same thing alot of people are having, car has no power taking off, kinda like a manual trans trying to take off in 4th gear, when I slow down or come to stop trans shutters and most the time stops running and I got to restart, took it and had computer put on it and it said solenoid b, I had I changed but nothing, I think it even got worse, took it to dealership and after three weeks they told me they would recommend a new Tranny, well heck I knew if I changed the tranny it would fix it but I can't afford that, I'm just trying to fix the one I have, oh and also the rpm's running up around 3000 and sounds like its running probably in 3rd or 4th gear, please does anyone know what might be the problem instead of changing the whole tranny... Thanks for any info
Jay4366 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome