Tips for CV Halfshaft Replacement? - Chevy Cobalt Forum / Cobalt Reviews / Cobalt SS / Cobalt Parts
Transmission All about the Chevy Cobalt Transmission

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-19-2016, 08:28 PM Thread Starter
Prospect
 
Join Date: Jun 2013
Posts: 15
Tips for CV Halfshaft Replacement?

Hi, this is related to this thread:

https://www.yourcobalt.com/forums/sus...-ls-coupe.html

I'm replacing the halfshaft due to bad torque-steer on acceleration. The shaft occasionally clicks very loudly when coming to a stop sign when the shafts are straight, but for some reason it doesn't click while turning. The halfshafts are the only original part of the front-end left on the car (other than the knuckle).

Last week I accelerated from a stoplight on a slight incline after a rainstorm and the car skidded a foot or two towards the shoulder and could barely make it up from the stop; it was as bad as wet snow or ice. I was told by a mechanic one of my shafts was failing, but I'm not sure which side. Online they say a hard pull to the right means the drivers-side shaft has failed, so I'm trying to replace that side first (this is a getrag m86).

Removing the old one was easy, other than pushing everything out of the way and accidentally pulling the brake hose. Removing the brake hose and having brake fluid spill everywhere just made things worse. Plus I had to find new copper washers.

Installing the new one on the rotor (outer) side was very easy and the splines match perfectly. However, the inner c-clip is protruding much more than the stock c-clip, and I can't push the differential side into place. I accidentally thought the axle was in and started the car, and went nowhere (in fact rolled backwards...no limited slip here). I'm getting so frustrated I might just put the old shaft back in so I have a working car again. Was just wondering if anyone has had problems putting a surtrak-trakmotive axle into a cobalt.

Thanks,
gbreadman is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-26-2016, 06:18 AM
Newcomer
 
Join Date: Aug 2016
Posts: 7
I don't know if this helps or not but I was working on one with the automatic trans and had a hard time getting the axles in as well. I ended up just having to rotate it slightly and make sure rotor side wasn't touching anything and just pushing as hard as I could. If eventually popped in and clicked. Maybe you can have a friend push on the rotor side while you're lining it up at the trans side and see if it goes.
mrspeedy69 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome