Chevy Cobalt Forum banner
cel
1-8 of 9 Results
  1. Problems and Service
    This is my first post on this forum, but I figured I'd give it a shot since there is a lot of good information and a lot of knowledgeable people out here. About a month and half ago I had gotten a CEL. It happened when I once stepped on the gas after taking a left turn. It could've happened...
  2. Transmission
    I have a 2006 Cobalt LT coupe 2.2 at 130K miles. Ran great since I bought it around 124K miles. A little background of what I've done since what I'm going to explain started: Replaced both up and downstream O2 sensors as they were bad, and changed out the exhaust (catback) since it was...
  3. Problems and Service
    This morning I experienced the most bizarre problem I have ever had with a vehicle. I started my '10 Cobalt LS1 engine (cold, high 60s) and noticed that the running engine was making a loud clicking sound. After about 20 seconds of running the engine with the clicking noise I decided to turn...
  4. Problems and Service
    Hey everyone I have been having some extra problems with my 2007 Cobalt SS sedan lately, and I say extra because ive been having a CEL (over the past year) which ive had read before and it was a rich code, I dont remember the code but I believe it was bank 1 rich. Anyway, in the past 2 weeks I...
  5. Problems and Service
    About two months ago my car threw a code for a multiple misfire, I changed the coil, plugs, and wires.. None of this fixed the issue, so I checked valves and fuel related issue, still no change. Finally, I replaced the ignition control module, which fixed the issue. Now the misfire is back...
  6. Problems and Service
    I own a 2006 Cobalt LT sedan. My CEL comes on whenever the heat or a/c is used, then goes back off after a few days of not using them at all...any ideas before I have to hook it up to a reader?
  7. Problems and Service
    Hi everyone. I recently had the check engine light come on and when I scanned it, it gave me the P0449 code. I noticed that there hasn't been the usual tapping sound from the trunk after starting the car, so I replaced both the evap canister solenoid valve and the purge solenoid valve, but the...
  8. Problems and Service
    Since last feb. when I got gas siphoned out of my tank my CEL has been coming on and usually staying on. The codes has been the following: PO455: EVAP System Leak PO496: EVAP High Purge Flow My MPG has gone down some. I went from mid 30's to upper 20's. Any ideas as to what the problem is...
1-8 of 9 Results
Top