Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
745 Posts
Discussion Starter #1
do they make wideband o2 sensors for the cobalt?
ive been lookin more into this a/f/r controller.
close friend has integra, and he said he loves to be able to tune it like this.
not boosted or anything, just seeing what you guys thought about it.
 

·
Say What again!
Joined
·
6,037 Posts
Yep. Just weld in a bung into the downpipe and you're all set.

I have the Innovate LC1 kit with the DB gauge, and love it.

AEM, Autometer, and others all make kits.
 

·
Say What again!
Joined
·
6,037 Posts
i have the aem uego wideband and it's a very nice all in one gauge. they go for about 200 shipped too.
I've heard many good things about that one too.

Just make sure you buy something that gives you a calibration option (aka - not an Auto Meter), since sensors "drift" over time.
 

·
Registered
Joined
·
992 Posts
yeah i got the AEM uego and its pretty neat....cost me about 200 shipped. comes with an o2 sensor just weld in the bung they give you and your set. super easy to hook up
 

·
Say What again!
Joined
·
6,037 Posts

·
Registered
Joined
·
745 Posts
Discussion Starter #8
my cel is on, and its telling me "bank1 too lean" wtf. how can i make it not lean out so much? do you have a clue of what would cause this?
 

·
Say What again!
Joined
·
6,037 Posts
Well, there's only one bank, so it's one of the cylinders - but lean means you don't have enough fuel - so somewhere something isn't getting enough fuel...
 

·
Registered
Joined
·
992 Posts
my cel is on, and its telling me "bank1 too lean" wtf. how can i make it not lean out so much? do you have a clue of what would cause this?
check out your injectors just make sure errything is in correctly, check your fuel rail and back just check for any leaks or such that would be stopping the pressure
 

·
Registered
Joined
·
1,890 Posts
o2 sensor bank 1? could also be a faulty sensor. you'll get an o2 heater circuit code soon if that's the case. if not, could be a fuel issue.
 

·
Registered
Joined
·
745 Posts
Discussion Starter #12
cel been on for like a year now lol. im thinking i need a new fuel filter. i have almost brand new injectors. everytime i get gas i could get 3 gallons or 10 gallons, and no matter what, when i start it back up it wants to die. fuel filter? 75k miles on it?

---------- Post added at 02:32 PM ---------- Previous post was at 02:24 PM ----------

instead of monitoring a/f, can you tune it also? on my friends he has a controller that goes with it where he can richin or lean it out a little bit to squeeze a little more power
 

·
Say What again!
Joined
·
6,037 Posts
Could be the filter with 75k miles on it - check your fuel pressure at the rail.
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top