Chevy Cobalt Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
mod and car info.
05 cobalt ss/sc
3in pulley
#60 injectors
Cold air intake
tuned by zzp
short throw shifter
long tube headers
straight pipe exhaust
bc coilovers

so here it goes... a few months ago driving light to light my car went in to eng power reduced mode out of no were... went to a local auto zone to pull the codes but i cannot remember the code it threw time because it was a while ago but i ended up disconnecting and reconnecting my battery and it went away and didnt come back so i just ignored it...
few months down the road i install a W.O.T box... install went fine everything is hooked up correctly and works great... about 2 weeks later i start getting thrown back into eng power reduced mode once again. this time i am getting a P2138 code (Throttle/Pedal Position Sensor/Switch D/E Voltage Correlation). it happens intermittently... can be with in 5 mins of driving or can happen 45 min of driving. So far i have replaced the throttle body with one from a spare 2.0 ss/sc engine i have from a parts car, i have replaced the map sensor on top of the supercharger. i have also removed and cleaned my MAF sensor, only thing i have not replaced is the throttle pedal sensor/ pedal assembly. now dont get me wrong i do not mind buying the throttle pedal sensor and replacing it but i have a feeling that replacing it may not fix the issue.

is there a way to tune this out? i own hptuners and if it is the wot box causing the issue is there a way to change the tune to ignore it?i have alredy tried setting the P2138 to do not report but in doing this the car still goes into limp mode but because it cannot produce the P2138 code it instead throws a really odd bad pcm code but i have since turned the P2138 code back on and am now stuck with it...

has anyone had this P2138 code show up after installing a W.O.T box?

what should i try next? just so tired of having to drive around with my laptop connected and clear the DTCs to get out of limp mode...
 
1 - 1 of 1 Posts
Top