Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I had an engine swapped into our car by a backyard mechanic and used the crank sensor from the old engine but all other wiring, plugs, coil packs, etc came with newer engine.The guy did the security and case relearn, etc and all the lights etc were going and clicking. When we turn the key now, all the normal lights are there for a few seconds and all go away except the air bag light and there seems to be nothing else..no start, or even a noise attempting to start. Power Steering and Fuel Low are displayed with the key on..the security light goes out with the rest after a second or two.
We are not sure where to go from here..,we jumped the starter from the relay pin just to be sure it wasnt the starter (turns over but wont start) Fuel pump comes on with the key (can be heard) but thats it.

Any help would be greatly appreciated..Thanks!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
any ideas? anyone?
I've gone through pretty much any posts I could find on motor or body swaps and none seem to have my issue..its not a security issue, (the light comes on when key is turned and goes out with the rest in seconds) it shouldn't be a grouding issue as all post and terminals have been cleaned up and retightened.

Could it need relearned again? the guy has done the 11 mins on 30 seconds off procedure twice now...
 

·
Registered
Joined
·
5 Posts
Following I'm in the same boat with taking an 2.4 ecotec from a g6 and swapping it to my cobalt it's the same motor ect same exact problem someone help please
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
I figured this would be the best place to ask...maybe its a new complicated issue..? Dealer of course wants it towed in to them and I may have to go that route but was hoping not to have to!
 

·
Super Moderator
Joined
·
11,821 Posts
Are you sure that you can drop an 08 into an 07 without changing the ECM? Let me check something. I believe I've seen this problem on here. Be right back.

---------- Post added at 12:57 PM ---------- Previous post was at 12:53 PM ----------

Okay thought the crankshaft reluctor ring was different between the years but they use the same GM#24424855
 

·
Super Moderator
Joined
·
11,821 Posts
You checked every fuse right? Even the big BCM fuses.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
all fuses were removed, checked for corrosion, replaced..same with the relays..as well, the ground was removed, cleaned with a wire brush and replaced..it is the original pcm and crank sensor with wiring harness included with new motor..

Thanks for any ideas
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top