Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi All. Since my ignition switch was replaced about 2 years ago, I've never had an issue w/my cobalt.....until today. Took my son to school, car started and ran perfectly. Come out of the school to head home and car is doing nothing. When you turn the key, the radio, lights will work, but it just makes 1 click then nothing. All fuses have been checked and we have tried to jump it, still nothing. Ended up having it towed home. Any suggestions?
 

·
Premium Member
Joined
·
11,821 Posts
Did you check the big fuse in the trunk? Or maybe your starter went for a crap. Maybe the ground strap on the starter broke from rust and corrosion. Could be a lot of things start eliminating. Do you only have one GM?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Only 1 GM. Fuse in trunk is fine. Checked it before attempting to jump it.

---------- Post added at 04:08 PM ---------- Previous post was at 04:07 PM ----------

After all the "idiot lights" have gone out, the only one left on is the check engine one.
 

·
Registered
Joined
·
949 Posts
Next step would probably be to see if the ground strap on the starter is broken like Coby mentioned.


Since you've got a CEL, you might try reading the codes to see if it helps. If you can somehow get it to Autozone, they'll read codes for free, otherwise, a cheap scanner can be had for like $15 on Amazon.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top