Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 20 of 26 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1 (Edited)
11.3 mpg need help please

2010 Cobalt LT 2.2L 62,000 KM
No fluid leaks, no warning lights, has a new air filter and all 4 tires are 34 PSi, new spark plugs, STP Complete Fuel System cleaner

I dont drive fast at all and never heavy on the gas at lights
If the Speed limit is 50 KM im doing like 35 lol My average speed it 29 KM per hour
I use regular fuel
it just had an oil and oil filter change about 2000 klms ago

I have no idea about cars and such I was just wondering if someone could help me with what i can look for when it comes to fixing this.

Its out of warranty now so Im kind of left on my own

Thanks a lot for the help. I really appreciate it

Edit: Added information
Its calculated MPG the display actually shows worse
Just hd the car scanned for codes and nothing come up!
 

·
Levee
Joined
·
3,210 Posts
Any check engine or warning lights? Any bad smells? Any misfires or anything wrong that you know of besides bad gas mileage?
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4
Any check engine or warning lights? Any bad smells? Any misfires or anything wrong that you know of besides bad gas mileage?
No warning lights
No smells
There is a Missfire but its very un noticeable..its been there since i got the car about 12000 klms ago but i was getting 34+ mpg then..I plan to replace all 4 spark plugs this week but i really feel this cant be the problem ..can it?

Are you going by calculated mileage or what your dic tells you?
Calculated the Display is actually worse
 

·
Levee
Joined
·
3,210 Posts
Bad plugs could give worse gas mileage, but not that bad. Have you tried to use any type of fuel system cleaner?
 

·
Registered
Joined
·
3,127 Posts
get your car scanned for codes even if there is no check engine light on. some codes don't illuminate the light.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #8
Replace fuel filter and plugs
First thing Monday morning..
Can a fuel filter be Do It Yourself? Ive done lots of small engine repair so I imagine a fuel filter is somewhat easy

get your car scanned for codes even if there is no check engine light on. some codes don't illuminate the light.
Will do thanks for that I will also do this

---------- Post added at 08:46 PM ---------- Previous post was at 08:44 PM ----------

Bad plugs could give worse gas mileage, but not that bad. Have you tried to use any type of fuel system cleaner?
I plan to change plugs and fuel filter monday and no i havent tried any cleaners yet but I will also on monday
 

·
Premium Member
Joined
·
3,860 Posts
Don't mess around with fuel systems yourself if you can avoid it. The fumes can overwhelm you and the risk of fire is great. Better you take that to a certified mechanic I would say.

There is a possibility your brakes are dragging. Do you feel as though the car decelerates quickly when you let off the gas?
 

·
Registered
Joined
·
42 Posts
Discussion Starter #10
Don't mess around with fuel systems yourself if you can avoid it. The fumes can overwhelm you and the risk of fire is great. Better you take that to a certified mechanic I would say.

There is a possibility your brakes are dragging. Do you feel as though the car decelerates quickly when you let off the gas?
Thanks for that advice I may just take it
Im not entirely sure about the brake thing becuase this is my first ever car and I wouldnt know what I should be looking for..if this helps at all..I find the car doesnt roll very good but what exactly is good when i dont know what to be looking for ;)

I understand I could be up against a million differnet things here that could effect gas mileage and all of your help so far is very helpful to a person who has no clue about this stuff..at the very least I could seem like I know what im talking about if i do have to bring it to a garage :p
 

·
Levee
Joined
·
3,210 Posts
Honestly if it was the brakes, you would see a lot of discoloration in your drums/rotors. Check your front brake rotors, see if there is any blue discoloration on them. If not, try to pull up on your e-brake. If it is kind of tough to pull up then we are on to something. If your having issues getting it to roll then it sounds like brake drag to me.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #12
Honestly if it was the brakes, you would see a lot of discoloration in your drums/rotors. Check your front brake rotors, see if there is any blue discoloration on them. If not, try to pull up on your e-brake. If it is kind of tough to pull up then we are on to something. If your having issues getting it to roll then it sounds like brake drag to me.
Thanks for the help
I will look at this first thing tomorrow as its dark here now and will check the ebrake too

Im not sure if its having problems rolling..its just seems to me that when i do let of the gas it should roll further and faster then what it do but that could just be my own personal opinion and prefrence..It would be hard to explain something like that to someone unless they were sitting in the driver seat them selves :wondering:
 

·
Registered
Joined
·
42 Posts
Discussion Starter #14 (Edited)
I'm curious did you ever get this fixed?
Not yet still in the process

Will have more information on it tomorrow and will update thread as i get through this
Tonight I filled up with regular gas and used STP Complete Fuel System cleaner (wont see results until back on empty)
Putting in a new set of NGK LTR5IX11 Iridiums tomorrow

If those 2 things dont fix the problem my next step is to either replace the fuel filter or check with the dealer to see if can be inspected for problems and then replaced under a safety recall

and if that doesnt work then Im going to get my brakes inspected for sticking

And then if that doesnt work...well i dont know what to tell you because then your guess is as good as mine
 

·
Registered
Joined
·
42 Posts
Discussion Starter #15
Update on situation: Getting Worse

I replaced the 4 plugs with the exact ones that came with the car at factory and I ran a bottle of STP Complete fuel system cleaner through a full tank of regular gas. I have noticed a difference in power and starting the car but its still eating through gas like no tomorrow

Ive filled the car up on regular gas 87 and Ive only put 60 klms on the car around town since and Im sitting at 3/4 of a tank with an average speed of 16km per hour the display now shows 20.2L / 100 KM (11.64 MPG)
This is all calculated from a fresh reset of everything I could with the display. Originally before i did this i was getting 16.7 so it actually has gotten worse
(which is no fault to the plugs or fuel cleaner) I just think I never found the problem yet

Heres the thing

Its winter here with temps of minus 10 degrees Celsius on average. Last night I sat in the car letting it warm up for around 20 mins while doing so i was watching the display unit for the MPG
While at idle it went from 20.1 to 21.3L / 100KM..
Also when I moved the car i got out and checked the ground under the car and not a single drop of any liquid to be found

My question is
Is that normal for that to jump so high just from sitting? Im wondering if thats a sure sign of something bad like an o2 sensor (keep in mind I dont get any check engine lights) or a sign of a bad fuel filter.

This is so frustrating and hard on my wallet right now :(
Thankyou so much to everyone that has been trying to help me out with this
 

·
Super Moderator
Joined
·
11,821 Posts
Well if you're sitting in the yard idling you're not getting a lot of mpg's. No need to warm up the car too long after start-up. After 30 seconds if windows are clear you can go. The ecotec is all aliminum block and head so everything expands at same rate, no need for prolonged warm-ups. If your average speed is 16 kms no wonder your mileage is so bad. Most cars will read ≈40kph with around 9-10 liters per 100klicks. Anytime you're idling you're wasting gas and lowering your MPG. What you need to do to clarify this delima is to go take a cruise at 100kms/h for 30 minutes if you still get 15l/100k then you have a problem. Bring the car to 100kms/h reset and watch mpg monitor. it should be below 8 for sure. My 07 is 7.3 @ -10°C.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #17
Well if you're sitting in the yard idling you're not getting a lot of mpg's. No need to warm up the car too long after start-up. After 30 seconds if windows are clear you can go. The ecotec is all aliminum block and head so everything expands at same rate, no need for prolonged warm-ups. If your average speed is 16 kms no wonder your mileage is so bad. Most cars will read ≈40kph with around 9-10 liters per 100klicks. Anytime you're idling you're wasting gas and lowering your MPG. What you need to do to clarify this delima is to go take a cruise at 100kms/h for 30 minutes if you still get 15l/100k then you have a problem. Bring the car to 100kms/h reset and watch mpg monitor. it should be below 8 for sure. My 07 is 7.3 @ -10°C.
Nah I never warm the car that long I just got caught up in watching the display this one time lol
I let the car warm for max 5 mins or until coolant reaches 20 degrees Celsius (what ever comes first)
I will do that and give it a try for sure
Thanks so much for the help
 

·
Registered
Joined
·
40 Posts
If you have a misfire it will only get worse, and will actually cause damage to the engine over time. So I can see where the fuel will be going like crazy. Regardless if you got 35mpg before it will get worse as time goes on. Now, it could also be the -10 weather causing problems. I also notice you keep adding stp fuel treatment. Try to stop using it, and see what it does. It is just a waste of $ anyway.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #19
If you have a misfire it will only get worse, and will actually cause damage to the engine over time. So I can see where the fuel will be going like crazy. Regardless if you got 35mpg before it will get worse as time goes on. Now, it could also be the -10 weather causing problems. I also notice you keep adding stp fuel treatment. Try to stop using it, and see what it does. It is just a waste of $ anyway.
Im not sure if you read all the comments in this thread so ill update you incase you never

The miss in the engine is now gone since I have replace the Spark Plugs but gas issue to persists
and Ive only used the Fuel System Cleaner once and dont plan on using it anymore for at least another 20K
 

·
Super Moderator
Joined
·
11,821 Posts
Next time try
 
1 - 20 of 26 Posts
Status
Not open for further replies.
Top