Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
248 Posts
Discussion Starter #1
not the whole cluster but just the spedometer. it is stuck at 0 mph

could this be the wiring or a fuse or just the whole cluster needs to be replaced??

i dont wana buy a new one and find out it still dosnt work.

any ideas??
 

·
Levee
Joined
·
3,210 Posts
Might be a fuse. Check your fuses for your cluster. Does your ABS light come on? When you turn the key on, does the gauge move at all (only turning the key from off to run *NOT* starting it)?
 

·
Registered
Joined
·
248 Posts
Discussion Starter #3
the spedometer arrow thing never moves at all...the car is actually my moms and i think all the other lights work.

how do i tell if a fuse is blown??
 

·
Levee
Joined
·
3,210 Posts
When you pull it out of the fuse panel the metal in the plastic will be blown apart. Ask if the ABS light is on. It sounds to me like a VSS to me. If it is, the ABS light will be on. If not, then the speedo isn't getting input from the ECU.
 

·
Levee
Joined
·
3,210 Posts
If the needle doesn't move, it's more than likely the cluster.
 

·
Registered
Joined
·
474 Posts
even if it is the cluster, it's very cheap and simple to replace, you just have to go to the junk yard, I bought one for my cav for like $20, and takes about 20 minutes to swap them out
 

·
Rocket Power
Joined
·
711 Posts
Sounds like a VSS to me...I'm not familiar with Chevy's but My Ford Taurus suffered from the same symptom. Turns out that there were 2 VSS parts, one was easy to change on the top of the axle, but my problem was the driven gear part deep inside the tranny.
 

·
Levee
Joined
·
3,210 Posts
^^ These are the same way, but if a VSS is out, the ABS light would be on, the ABS would be inactive, and the needle will still move if the power to the cluster is turned on. If the needle doesn't move at all, then it's the cluster. ;)
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top