Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello gang, just found this site, and am in need of some help. I have a 2005 Cobalt, with an automatic trans. 107,000 miles. Car has shown NO trans problems whatsoever before the issue described next. Wife was sitting at a red light the other day, and when she went to take off, the car gets to around 40 MPH, the trans will not not shift, just revs up. There are NO codes showing up whatsoever. No check engine light at all. I tried the TCM fuse and it is fine. I disconnected the battery, and problem persists. Car seems to have no other issues. Anyone else ever have this issue? Any suggestions? Thanks in advance! - Drue
 

·
Super Moderator
Joined
·
11,821 Posts
If you don't have a check engine light you may still have history codes or pending codes. Is anything else acting up? Maybe re-seat the BCM connectors and change the PCM/TCM fuse on the BCM fuse block. It might be pitted or corroded.
 

·
Registered
Joined
·
4 Posts
My balt has been having this issue. 05. Around the same milage 106XXX I never found out exactly what's doing it. My balt only does it when its cold. I tell her she's temperamental. I'm from northern Indiana so were coming into warmer weather and it practically stopped. Just early morning drives or late nights after it hasn't been driven a while. I'll be following to see if you find out for sure.
 

·
Registered
Joined
·
20 Posts
My daughter has 09 LT with 83,000 miles that had a spontaneous problem a couple months ago - out of the blue it started slipping, you had to gently accelerate but at 40+ it was fine. Had a local shop diagnose. Could not find a bad valve or actuator (?) or any code.

Basically options were pull it out and have it rebuilt or replace with used. In order to get it resolved quickly went with used (50,000 miles) trans from recycler with 1 yr warranty.

Bottom line $1400 and back end of next day with no problems except resetting clock and date. (But still had radio presets!). At the same time I got a shifter for $50 and had it changed out because red tab that indicates gear position had broken a while back.

A couple months of regular use with no regrets. (There was an option for used trans with 30K for $1700 installed, but either way tranny has less than the car.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
2 Posts
Transmission maintenance for me includes:
Auto-Rx to liquify any gumny deposits
Xado revitalizant to repair-in-place wearing of metalic contact points/surfaces

Just turned 445K on a 2.2l 2007 Pontiac G5 sedan with A/C, power windows but not the front frog lights. And I do mean frog lights.

Good luck in your situation. Stay positive and look for solutions!
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top