Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
I live in South Carolina so it's not like its -20 degrees or anything. However, when it's about 30-45 degrees in the AM, when I try to start cobalt it starts and dies. It will rev up for a sec and then fall flat on its face. I can give it some gas, like a cold natured carb and sometimes get it to rev up and stay running. This morning it died like 10 times before I could get it to stay running!

I have check engine lights, but advanced scanner can't read them. I'm sure I have power to obdII because my little plug in insurance thing I have to save some $$ works. Originally when I bought the car it had bad cat code, replaced o2 sensors and didn't fix anything.

2006 cobalt 2.2 manual 2 door LS. 99,xxx miles.
 

·
Premium Member
Joined
·
2,068 Posts
Recently my car wasn't starting at all unless I let ithe key on the "on" position for a second, I had a hole in my gas line. Check under the vehicle and make sure there is no leak. This may not be the solution but it's a start lol

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
41 Posts
Discussion Starter #3
I actually parked on top of cardboard all last week after I replaced thermostat and drained coolant. No leaks as of yet. Thank god!!!
 

·
Registered
Joined
·
41 Posts
Discussion Starter #6 (Edited)
Spark plugs and fuel filter changed 1 year 6 months ago.

Ran FI cleaner last oil change 200 miles ago.

Clean TB is a good idea. I know I need new air filter.

It's like the "choke" isn't working. Like bad coolant temp sens not adjusting for cold temps and not dumping more fuel at startup.

I've read about "cat warmer" not functioning correctly??

Gas mileage hasn't changed. Still 38 when warm weather and 36 during winter months.

I have noticed it runs a little rich on startup when warm, when I backup I normally can smell fuel.
 

·
Super Moderator
Joined
·
11,821 Posts
What are the codes? Maybe your purge solenoid is stuck open.
 

·
Registered
Joined
·
41 Posts
Checked codes... had a long list. Including no MAF operation, vacuum/exhaust leak, on and on, something about being grounded out. However, he reset computer with the snap on tool and MAF and everything went back to normal giving a signal and everything. Did diagnostics and everything was in spec.

Now to drive and see what else pops up.
 

·
Registered
Joined
·
1,145 Posts
Which Snap On scan tool? Modis? Ethos? Did you have to use a K series key connector, should be a K5 (GM).

I still believe GM/Chevy still uses a Tech II, which looks like an old 80s prototype Gameboy or tetris machine. Hopefully its fixed :)
 

·
Registered
Joined
·
1,145 Posts
1 - 14 of 14 Posts
Status
Not open for further replies.
Top