Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 20 of 38 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
we have a 2006 automatic chevy cobalt 4 door car with 117,000 kms on it. The car was working fine never had a hitch, we heard a rumble in the car and a few days later we were making a turn and the car just stopped working in drive. The car still revs up but it won't move forward. Reverse works fine. The engine light has been on the car for awhile we had that checked on the computer at the garage and it was emissions or something like that and they said not to worry about it. They took the light off and within a day the engine light was back on again. We notified the garage and they said not to bother with it that chevys and gmc's are famous for it. When we took the car to the garage to see why drive was not working they checked the transmission fluid and said it was good. and they put in on a code reader and nothing showed. They told us that the transmission was toast. I am finding this hard to believe considering the car is not old and only has a little over 100,000 kms on it. and if the transmission was toast then why is reverse still working perfect. Does anybody have any ideas on what could be going on? Thanks :)
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
ok I will check it out and let you know what happens. I knows the garage didn't check no fuses, only the oil. What would of caused the rumbling noise that we heard a couple days before the drive decided not to work? Thanks for your reply's I will keep you updated my fingers and toes are crossed!!
 

·
Registered
Joined
·
4,647 Posts
these cars rumble and vibrate all the time, so it's hard to understand exactly where the rumble was coming from. i have a feeling it's your gear selector. if it was your torque converter, it wouldn't move at all.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #7
We checked all the fuses and they are all good. We tried putting foot on the brake, slamming the shifter from park to low, and from back to park and we started it up, all good but still no drive, rpms are good and its shifting good.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #11
no it will rev up and not move but as soon as its shifted to reverse it moves. I will get the garage to check it. I figured something show on the code reader but the garage couldn't pick up anything. Thank you so much for taking the time to help me :)
 

·
Registered
Joined
·
18 Posts
Discussion Starter #15
I didn't think it would be the transmission either or at least hoping and praying it wasn't. I still don't understand why the code reader wouldn't pick it up especially if it was a sensor or electrical issue.
 

·
Registered
Joined
·
4,647 Posts
switches are not expensive or hard to replace. do one more thing for me. put the car in neutral and try to start it. if it starts, turn it off. then put the car in drive and let me know if it tries to start or if it in fact does start
 
1 - 20 of 38 Posts
Status
Not open for further replies.
Top