Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello I've had nothing but trouble out of my 2006 cobalt I bought a year ago...I love my car but seriously one problem after another. Currently the issue is park/neutral fuse that keeps blowing. I have a warranty thru my car lot but it's getting to be a major pain. They thought it was breaker box so they replaced it but still having problems now they want it for a day to go thru all the wiring. Also when I go to shut it off the radio cuts off n starter is engaging to start. You hear a grinding noise but it's not every time. Also the service airbag light is on the dash. Starting to wonder if I just got a lemon...I've had the motor... starter... alternator... battery... ignition cylinder...all replaced in a year...n the fuse box also....just need some sense of direction I'm thinking computer issues...open for suggestions or ur experience that may be similar...ty Sweet Pea
 

·
Registered
Joined
·
266 Posts
i would message Coby7 he is the resident guru, he is an avid poster on most topics so he will probably know something about it, good luck!
 

·
Super Moderator
Joined
·
11,821 Posts
Firstly you bought a 10 year old car, problems are expected but you're listing a lot of problems. Maybe the previous owner didn't do all the regular maintenance or it was just driven hard. Or maybe you have a trigger happy mechanic that likes to throw parts at a problem he doesn't understand. My guess is that you have a frayed wire touching somewhere, verify the looms and harness wraps for breaks or signs of rubbing.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top