Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I am having issues with my 2006 Cobalt's steering column. I have intermittent power steering issues. I randomly stops working. The reason I categorized this as electrical is because at the same time the "service air bag" light comes on, the A/C blower stops working, and the windshield wipers stop working. The dealership tells me it is the steering column, but that doesn't pass the scratch and sniff test. I have seen numerous complaints about this problem across multiple chevy models. I had the dealership replace the power steering motor (recall), but the problem still persists. I've seen another post in this forum with similar electrical problems, but they weren't intermittent and the replacement of a fuse fixed the problem. Does anyone know what this could be?
 

·
Registered
Joined
·
922 Posts
First off, That's pretty wild, and I hope your not driving this everyday.... could he dangerous not only to you but to others on the road... I hate to say it, but if you really need the car I think you should let the dealer/shop take. Look at it and really figure it out. Is there a second dealer in your area that you can it to? I've done that here in VA one dealer was trying to put ss/sc injectors in my car to fix a loss of fuel issue, because they thought it was the ss based on the wing on the car... I took it to one of the other chevy dealers in my area and they immediately went to the fuel pump and changed it under the recall....

I'm just saying get a second opinion to make sure that they were right....
 

·
Super Moderator
Joined
·
11,821 Posts
Sounds like a loose ground to me if you lose several things at the same time. Check the ground mounted inside of the driver's side strut tower for corrosion or loose connection. Also the one under the coolant reservoir, it's the one for wipers.



 

·
Registered
Joined
·
5 Posts
This may seem to easy. My 2006 cobalt had power steering electric motor assist problems. It would come on and then off. I also had a problem with security Icon on dash. after 600 dollars at dealer it came back days later. I fixed problem couple days after that. The battery was dead and changed battery(electric motor assist problem solved). I have been told some have changed alternator. As I understand when the battery voltage or amps get low the computer does not want you to be stranded on the road and starts shutting down power to unnecessary function of the car to keep it running. Just something to check if systems come and go. The security was fixed when I used a new key which we got when we bought the car. The new Key did not have the security icon on the dash. We had a new key made off the one we have not use since we bought the car( security/communication problem solved).
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top