Chevy Cobalt Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey guys so im not a mechanic but after letting a friend use my car the other day he bought him down and busted a hole in the oil pan my mechanic repaired it and put everything back together and now the car won't start we've checked everything from the battery which is week but brand new two things under the car that if damaged could cause it not to start to fuses and we can't find anything wrong with it the engine is not seized and when I attempt to start it it makes a whirring sound and that's it we started looking at the sensors most recently and one seems bad the oil pressure sensor so replacing that today if anyone has any information on what we could have done wrong or not done or could be missing it would be a huge help we've been working on this for weeks and it is my only transportation thank you for all your help
 

·
Registered
Joined
·
21 Posts
Pleeeeeease use a period here or there... that paragraph of a run-on sentence is mighty hard to follow.

Whirring sound... is it turning over? Take a look at serpentine belt while you try to start it. If it's rotating, that means you have enough battery to start the engine. If it isn't, the battery is too weak to start it. Try jump starting it.

The car will start whether or not the oil pressure sensor is working.

Once you eliminate the battery from the problem, check the wiring on the front of the engine. There is a chance your mechanic disconnected the wires for the throttle body or injectors if/when he removed the dip stick tube.
 
1 - 2 of 2 Posts
Top