Chevy Cobalt Forum banner
1 - 5 of 5 Posts

·
Registered
2006 Chevy Cobalt LT 2.2L Automatic (just hit 222,222 miles)
Joined
·
6 Posts
Discussion Starter · #1 ·
I've had this 2006 Cobalt LT Sedan since Feb. or March of 2006. A few years ago, we started having issues with the fobs not wanting to work properly. Both had worn buttons (which we fixed) and one had loose battery clip. I ended up getting an aftermarket fob because the dealer wanted way more than I was expecting. Had a local locksmith reset the Fobs and other than the car always complaining of the battery needing to be replaced, it worked fine for another couple years. Then we started getting the old "knock, knock, knock, knock" from the blend door actuator. We replaced that and everything was fine for a while. About a year ago we stopped getting the battery notices and started having a weird issue. The fobs would work, but only if they were right next to the windshield above the receiver. Now, as of a week ago they don't work at all, and the plug at the trunk light is only getting 10.2 volts and barely lights up. The fobs are working fine, but the receiver can't detect them. I'm wondering if there's a wire loose or shorted near the RCDLR causing both issues. I've looked for a replacement RCDLR but I'm running into the problem of it being discontinued and no one having stock. My questions are: Is there some sort of antenna that may have come loose when replacing the blend door actuator that I could check? If not, can I replace the 21994227 RCDLR with a 25974373 for the 2007-2010 as long as I use the corresponding fobs (which I think is 15252034) or will I run into issues? I'm not looking for remote start, just want the keyless entry to work again. And what could be causing the low voltage issue with the trunk light? We recently switched to LED headlights which were supposedly CANBUS friendly, but I can't recall if the trunk light worked before then or not. Those seem to be the only issues, the keyless entry and that trunk light and both are vexing me. Sorry for the long post. I'm starting to pull out what little hair I have left.

Edit: 2006 Cobalt LT 2.2L Sedan no Pioneer System, no OnStar. (Vin # 1G1AL55F567702944) if that helps.
 

·
Registered
2006 Chevy Cobalt LT 2.2L Automatic (just hit 222,222 miles)
Joined
·
6 Posts
Discussion Starter · #2 ·
No one seemed to have an answer. As a follow up I bought 2 new 15252034 fobs and a new 25974373 receiver. The fobs arrived first and the got the new receiver a few days ago. Turns out the new one has a different plug and won't work unless I hack wires, but I don't want to do that even thou it's too late to return the fobs because now I'm not sure it would fix anything. I ended up getting 2 receivers from a 05 and a 06 at LKQ and still have the same issue with all 3 of the original 21994227 receivers. The remotes work, but only if I'm practically touching the fob to the windshield right above the receiver. Today I got a new original GM remote 22733523 and was able to pair it with the car, but again had to be within 8-12 inches of the receiver for it to work. What would cause this lack of range, and how can I fix it? Neither my original receiver nor the 2 from the LKQ yard seemed to have any sort of coax antenna so I'm clueless how to proceed. I'm worried that the issue could be the BCM itself.

Edited for info about checking for an antenna
 

·
Registered
Joined
·
1,095 Posts
First things first. How old is your battery and are the battery terminals clean?
That receiver is overly sensitive to its supply voltage. Then again after 18 yrs some of the internal filter caps may have aged out of specifications forcing you to look for a newer RCDLR unit.

look up the term. Patch antenna

try this experiment. Place your key fob on to the bottom of your chin while pressing the buttons and see if you get a little better range
 

·
Registered
2006 Chevy Cobalt LT 2.2L Automatic (just hit 222,222 miles)
Joined
·
6 Posts
Discussion Starter · #4 ·
The battery is brand new as of this weekend and the terminals are clean. Another problem that just occurred when swapping the battery, the 6-day new front passenger turn lamp isn't working, was too dark to pull it out and check to see if blown or just not working. I have an idea that my many issues may be caused by a little thing next to the battery called a current sensor, seems to send a signal to the BCM. They are cheap enough to replace, I just don't know which I need. There are 2 versions, 1 for 10-volt BCM signal and one for 5-volt and I don't know how to check which BCM came with this 06 Cobalt. I suspect it may be the cause as I can see it got wet at some point when the 3rd brake light was leaking. As far as using the chin trick, that was one of the first things I tried when I noticed the fobs still worked but at greatly reduced range. I remember doing that with an old Excalibur alarm I had on a different car long ago.
 
1 - 5 of 5 Posts
Top