Chevy Cobalt Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
2007 chevy cobalt.

One low beam stopped working so I went to replace the bulb, the old bulb was fine though, but now neither the running lights, or headlights, high or low beam, work. I can 'flash them pulling back on the headlamp arm, but that's it. All the signal lights, brake lights and backup lights work fine.

Any thoughts?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #2 ·
I was hoping for a response from someone by now. My original thought was that it was a the pcb relay which I think would mean I need to replace the fuse panel in the engine compartment. However, driving it down a bumpy road yesterday made the running lights come on for a while and then go back off, so I'm going to look to see if I can find a short somewhere. If someone knows the most common short locations in the lighting harness that would be helpful.
Or any other suggestion of what it might be would be welcome.
 

·
Registered
Joined
·
960 Posts
Your headlights have separate grounds. One for each bulb. You might wish to check them out. They are known to give problems just as you have described. Search the forum for
Ground location images
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
Ignoring those who don't actually read posts before replying...

The issue has something to do with the light sensor on the dash. Not sure if it could be a relay or what, but I do now know that if I cover the light sensor, everything works fine.
 
1 - 9 of 9 Posts
Top