Chevy Cobalt Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello All,

I'd consider myself a pretty good do it yourself mechanic but I am at loss with this one.

Prior to the issue, there was no problems with the vehicle. It is a 2008 Chevy Cobalt 2.2L with 199K. I've owned it since about 70K and it has always had its routine maintenance. The night before the issue, I filled up the gas, drove it to work the next day, no issues. When leaving work it cranked but will not start.

The battery is good after testing (charge, CCA etc)
Fuel pump works with good PSI
Fuel rail is good
All injectors are clean and have excellent and timed output
New spark plugs and coils
New starter
All fluids good
EVERY fuse was pulled and tested
The only code i got was P0016 and I replaced the camshaft position sensor for that code.

On crank, it sounds clean and normal. No engine sounds/rod/piston/cracks from what I can tell.

Sprayed starter into the intake on crank with no change, not even a putter. There is some normal deposit build up but nothing too bad and no sludge.

I have no idea where to go from here.

The only odd thing i discovered was that cylinder 1 has a very prominent spark while 2, 3, and 4 have a significantly weaker spark. I am not sure if this is normal. All plugs and coils were rotated to 1 and had a strong spark at 1, just not 2, 3, 4.

Thanks for the help! I just feel like I am at a brick wall. I think I covered everything but please ask if you need clarification.
 

·
Registered
Joined
·
139 Posts
Timing chain broke? 199k isn't too bad but it is up there. Pull a spark plug, crank engine, see if you are getting compression.
 
1 - 2 of 2 Posts
Top