Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Ok... installed the cruise switches on my 09 cobalt steering wheel alone with the wires. Brought it to the chevy dealer and he went through all the steps to turn on the cruise...doesn't work. By the way pin 61 is populates as I was told to check before. He doesn't know why it won't work. Am I missing any parts that I still need to install???any ideas....sure would appriciate any help...Thanks ,Dave
 

·
Not justice...Punishment
Joined
·
3,829 Posts
On a Cobalt XFE 5 speed LS cruise control is not standard. Most likely because cruise control is horrible for mpg.
 

·
Registered
Joined
·
1,218 Posts
Ok... installed the cruise switches on my 09 cobalt steering wheel alone with the wires. Brought it to the chevy dealer and he went through all the steps to turn on the cruise...doesn't work. By the way pin 61 is populates as I was told to check before. He doesn't know why it won't work. Am I missing any parts that I still need to install???any ideas....sure would appriciate any help...Thanks ,Dave
What year was the switches from? There is a difference in pinouts between years (At least with the HHR). See if the dealer will print you off a wiring diagram for the clockspring and switches. It should be a simple repin.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #5
Thanks Nighthawk for getting back. I was wrong there was no gray wire in pin 61. The guy at the chevy garage said I just need to find out where the gray wire that goes into 61 comes from and and I shoud be able to install a wire to make it work. Does this sound right??? He said that the cruise in the module is now turned on. I also tried a Rostra aftermarket and that wouldn't work either. Would like to get the OEM working before my daughter gets a speeding ticket going to college. 20 year old can't figure out how we used to drive before cruise....thanks, Dave
 

·
Registered
Joined
·
1,218 Posts
Thanks Nighthawk for getting back. I was wrong there was no gray wire in pin 61. The guy at the chevy garage said I just need to find out where the gray wire that goes into 61 comes from and and I shoud be able to install a wire to make it work. Does this sound right??? He said that the cruise in the module is now turned on. I also tried a Rostra aftermarket and that wouldn't work either. Would like to get the OEM working before my daughter gets a speeding ticket going to college. 20 year old can't figure out how we used to drive before cruise....thanks, Dave
That is correct, you will need to manually route a new wire from pin61 of the BCM connector to the appropriate place in the clock spring.

If you need some help with that, there was a how-to written up:

Electrical How To: Factory Cruise Control and Remote Radio Control Installation (2007- 2010) - Cobalt SS Network

As far as speeding tickets go, I can say right now cruise only somewhat helps provided they set it at the speed limit. I've set Cruise for much higher speeds before.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top