Chevy Cobalt Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I Have a a no crank no start condition..
No power to starter signal wire (pin 87 purple wire)
No power from ecm at pin 86 on crank relay.
pin 57 at ecm is getting battery voltage from PRNDL switch.
If I provide power to pin 87 on crank relay with key on, car will start and run just fine.
Assume it is a bad ECM not providing signal to start?
 

Attachments

· Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
In the attached diagram is has the purple/white commanded wire (pin32 in ecm and pin 86 in fuse panel) to be commanded wire. The green wire from prndl to ecm has power. Only thing I do not know is if the bcm is commanding the ecm to start when turning key. Gonna bring an analyzer home from work tomo.
 

· Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Check your grounds
I did. Removed and cleaned the one at trans and the one bolted to chassis. 🤷‍♂️ ecm is not sending power out to close the crank relay. Ordered a new ecm, still didn't work.
Check bcm while cranking and shows the command. Weird, it started out as intermitten, and is now an everytime thing.
 

· Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
Well, I indeed figured out the issue.
Ground stud at front of trans. Cleaned it previously.. this time I cut it and replaced the eyelet. Burning fuel again with this one.

So with that being said.. anyone reading this that has any electrical issues... go to the ground stud in front of trans. Has 6 black/white wires.. cut it back and replace the eyelet.
 
1 - 7 of 7 Posts
Top