Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
So I just had a JVC unit installed in my 2010 chevy cobalt it was professionally installed and it worked perfectly fine once installed. 2 days after it was installed I was driving to work it turned on perfectly fine! as soon as I pulled into the parking lot my dashboard gauges and meters stopped working. Once this happened a couple of dash symbols came on which was a car with a padlock on it my seatbelt symbol and the passenger seat belt symbol .I turn the car off and turned it back on and it turned on perfectly fine so eight hours later once I got off work I tried to turn the car back on and it wouldn't even start wouldn't even turn over. I got it towed to the dealership and once they took the Radio out the car turned back on. When I took it back to where was installed they said something about them having to install the radio with an OnStar harness so it could work. I was just wondering if anyone ever heard of anything like this because I don't want them to install the radio and my car cuts off again
 

·
Registered
Joined
·
6 Posts
I put a double din in my ss with a generic harness. I lost my chimes and on star and my car works fine. I really something about your radio is attached to your bcm.
 

·
Super Moderator
Joined
·
11,821 Posts
Tell them you want your money back and that you will get it installed at a real professional place.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top