Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi, my name is Chris from Cincinnati. My 2010 just turned 100k. I bought it new from the dealer with only 15 miles on it. I have loved the car thus far. No mechanical issues except a wheel bearing. That is until lately. At around 90k the transmission started acting up. Pulsating around 20 - 40mph between 2 & 3k rpms. It was hit and miss. One day it would act up and the next no issue. Had the regular maintenance done as suggested and had fluid and filter changed at 91K. Issue was still a hit and miss. Took it back to my mechanic and all fluid levels were good. He drove it, nothing happened. It actually quit for about a month. It hasn't been acting up often. Then today, here we go. Only this time the Check Engine warning came on... I can't figure it out. Any help is greatly appreciated.
 

·
Registered
Joined
·
1 Posts
Hello! I am just running into this exact issue. Got the car at 117 miles on it. I'm at 88,000 miles. No issues hardly on the car at all except the wheel bearing in my first year of ownership.

This started two weeks ago. I took it to Autozone which ran the code machine on it to see what is happening.

I got the following readout:
P0700 -Trasnaxle Control Module (TCM) Malfunction
P0976 2-3 Shift Solenoid (SS) Control Circuit Low Voltage

My light comes on intermittently and it will work "fine" for a bit, but then starts having the RPM stuck at 3.2 while driving at a steady speed.

I haven't taken it in yet as I'm a bit paranoid of the cost of the repair.
 

·
Registered
Joined
·
3 Posts
Hello! I am just running into this exact issue. Got the car at 117 miles on it. I'm at 88,000 miles. No issues hardly on the car at all except the wheel bearing in my first year of ownership.

This started two weeks ago. I took it to Autozone which ran the code machine on it to see what is happening.

I got the following readout:
P0700 -Trasnaxle Control Module (TCM) Malfunction
P0976 2-3 Shift Solenoid (SS) Control Circuit Low Voltage

My light comes on intermittently and it will work "fine" for a bit, but then starts having the RPM stuck at 3.2 while driving at a steady speed.

I haven't taken it in yet as I'm a bit paranoid of the cost of the repair.
Not sure if u have fixed issue but good luck on finding a Dealership that will even fix it and I Know solenoid labor cost Is over 600 bucks, if I knew all this before, I would bought used Tranny and just Switched it out but now I'm around 800 in cost and my Cobalt still doing the same problem as before if not worse. If your not in my situation which is owe more On that car than it's Worth I would find Nearest car dealership and trade it fast as I could get There. Good luck with yours and wish the best for you if u haven't got it fixed yet.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top