Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Being of last month had new timing chain , spark plugs, oil change and Radiator flush done to car.
Starting and running fine. Then few days ago get out of store will not turn over. Read codes P0013 pops up replace
get it to crank but not start. New codes P0016 and P0017 cranks will not start clear codes, they came back.
Have spark and gas, will crank but not to full start. any idea please. lost and do not have time to keep adding more parts. Thank you!
 

·
Super Moderator
Joined
·
11,821 Posts
Sounds like you lost the crank position sensor to me, check connection. But can't be sure because I'm way over here.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I apologize for misunderstanding,(P0016andP0017) CKP intake an exhaust were both replaced. Fuses were checked. Tries to start but will not fully turn over.
 

·
Super Moderator
Joined
·
11,821 Posts
Cam actuator is not the crank position sensor. If you are having crank to cam correlation errors you will not have ignition at the proper time, therefore no start. The crank sensor is at the bottom of the block near one end of the crank.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Thank you so much Coby7 . Had to charge battery, other codes cleared. Did a new reading it came up p0341. But I am definitely checking the crank shaft sensor. Looking at it found a yellow purple Twisted wire passenger side on the back of engine passenger side. that seems to be loose or not connecting correctly. Was not secured down when timing chain was done last month. No I did not do timing chain myself, to small for that.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top