Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
2,204 Posts
Discussion Starter #1
The old lady's G5 tossed a few codes the other day...

Got one for a oxygen sensor bank 1 (guessing it's crapped out...car has about 70k on it and nothing has been touched...all the wiring looks good and everything is plugged in still)

Figured the coolant temp sensor took a shit too as I got numerous codes for coolant not up to temp, etc. I tried flushing the system and it read for about half a day, then gave me the COOLANT TEMP: ---* on the DIC again.

***ker.

Figure it's time for a new temp sensor or t-stat stuck open? Maybe an o2 as well?

Anyone else ran into these issues with a car that's only 3~ years old?
 

·
Registered
Joined
·
3,127 Posts
O2 sensors seem to be typical. Chev sucks with coolant temp sensors. Gp's had problems with theirs too
 

·
Super Moderator
Joined
·
11,821 Posts
Might just be a bit of corrosion on the temp sensor tab. Try cleaning it first.

As for the O2 clear the code and see if it comes back. Excessive moisture in the exhaust may cause an out of place or eratic O2 code. GM has a bulletin on this somewhere.
 

·
Registered
Joined
·
2,204 Posts
Discussion Starter #4
O2 sensors seem to be typical. Chev sucks with coolant temp sensors. Gp's had problems with theirs too
GP's had the issue because of the way it sat in the radiator and the dex would sludge it up.

Most of the time the sensor was never bad, just too covered in crap to read.

Might just be a bit of corrosion on the temp sensor tab. Try cleaning it first.
That seems easy enough. Guess I'll give that a go around as well.

As for the O2 clear the code and see if it comes back. Excessive moisture in the exhaust may cause an out of place or eratic O2 code. GM has a bulletin on this somewhere.
Cat's ever clog on these cars? That was the next thing I was leaning towards.

The CEL's apparently came back on her drive to work this morning but it might just be from the insta-frost we had and 40+* drop in temps over the weekend. 75* one day, that night...ice and 29*. Love it. I'm gonna re-check tonight for the o2 code regardless.
 

·
Registered
Joined
·
3,127 Posts
Cats do clog on these. A lot of ppl mention getting theirs replaced before exhaust warranty runs up. Should be smelling eggs or something or a loss of power
 

·
Registered
Joined
·
2,204 Posts
Discussion Starter #6 (Edited)
Whelp.

Two days...cleared codes the 13th.

She hasn't had anything since.

Might just toss in a new ACD o2 anyways for lulz.

Thanks peoples.
 

·
Registered
Joined
·
3,127 Posts
Hope it works out for ya. I personally do overkill so I changed mine the first time a code popped up
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top