Chevy Cobalt Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2007 Cobalt. I just replaced the master and slave cylinder and after getting it back together the light came on. Had to get a jump start and was told battery was bad. Replaced battery and light came back on. Had to get another jump when the battery was drained and was told it's the alternator. Got a new alternator but light is still on? Have no idea what to do. I don't want to be driving and the battery drains again and I have to call AAA again. What could it be? Please help?
 

·
Registered
Joined
·
4 Posts
I have a 2007 Cobalt. I just replaced the master and slave cylinder and after getting it back together the light came on. Had to get a jump start and was told battery was bad. Replaced battery and light came back on. Had to get another jump when the battery was drained and was told it's the alternator. Got a new alternator but light is still on? Have no idea what to do. I don't want to be driving and the battery drains again and I have to call AAA again. What could it be? Please help?
Go back and check all your wires something must be unplugged or damage to a wire could be a small break in a wire
 

·
Registered
Joined
·
156 Posts
How did the car get jump started? Did they connect cables to the jump posts under the hood? Or did someone charge the battery directly in the trunk. It isn’t recommended to charge the car directly to the battery because it can damage the electrical system.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thank you for your suggestions.

@Terry smith. I'm going to go look closer again. Thank you.

@CodyATE6 It was jumped from the posts under the hood. And the battery charged directly but not hooked up.
 

·
Registered
Joined
·
1,044 Posts
agreed go back check your wiring around the fuse box, maybe something was loosened during your maintenance.
 
1 - 5 of 5 Posts
Top