Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1
this car has to be a death trap! LOL
i cranked up my car tonight leaving work and noticed my light on my volt gauge was out. i pulled it out of the pod and pulled the bulb out. Just as i pulled the bulb out my power steering goes out, service air bag along with the AB light which is very dim. All of this is which popping up on the DIC. my amp does not cut on to my subs. the AC turns on but won't do nothing else, wipers dont work either. checked the fuses for them, all look good. as far a electrical mods go i have, system, neons outside, strobes inside and the volt gauge. i think none of these have to do with the problem at hand. they all work but the volt gauge. the car is still under warranty but i dont want them giving me shit at the dealership about what i have done to it. what should i do? thanks guy for your responses.
 

·
I cut stuff
Joined
·
6,238 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #3
PM'd camopaint,
come on guys, i know one of you has to have cobalt intelligents of cosmoclitic proportions. i kno i cant spell. LOL
 

·
Registered
Joined
·
67 Posts
Discussion Starter #5
checked them, they all looked good, should i check ALL of them and not just the ones where the problems are happening? thanks for the response.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #7
haven't checked them, could that maybe be the problem? and if so how would i fix them? thanks man.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #9
where would they be located and how do i test them? lol,
thanks for putting up with my noobness. lol
 

·
Registered
Joined
·
67 Posts
Discussion Starter #12
got it fixed, all it was... was a 20 amp fuse that blew. everything is back to normal. now to give her a good cleaning! lol
close thread.
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top