Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello forum,
I am driving a 2008 Cobalt LS with 105,000 miles, manual 5-speed.

Several months ago I tried to install an after-market cruise control, but could never get it working. I believe I set the wiring back to normal.

I just discovered that all three brake lights are illuminated brightly, as if I'm stepping on the brake, when the hand brake is off. The position of the (foot) brake pedal appears irrelevant. Pulling up on the brake pedal or depressing it has no effect, but there is little or no free play pulling it up. With the engine running or with the key in the ignition position, brake lights are on when the hand brake is off. Pull up on the hand brake, and the brake lights go out.

If the engine is running and I turn on the headlights with the hand brake up (on), the left and right tail lights illuminate at half brightness, normal for running lights. If I then release the hand brake, all three tail lights go to brake light intensity.

The four-corner hazard flashers work. The brake fluid is just above the medial seam on the reservoir.

I applied dielectric grease to both multi-pin connectors in the body control module by the front passenger's left foot. No change. Applied more. No change.

I pulled and reinserted every fuse and grey block (relay?) in the engine compartment fuse collection. There was no continuity between any of the four pins on the CMHSL (center-mounted high stop light) relay. The CMHSL fuse tested good.

The only thing I can guess is that the sensor or switch at the brake pedal is constantly activated. I see the metal rod attached to the brake pedal which goes forward towards the engine bay, wrapped by a rubber boot. Higher up on the pedal are all kids of gismos - is that where the brake light sensor is? Any tips on adjusting it?

Thank you very much.
 
1 - 1 of 1 Posts
Status
Not open for further replies.
Top