Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 1 of 1 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
So i just got an engine swap done in my 2006 ss/sc 2.0L, i also got a brand new Power Torque Diaphragm clutch put in since my old clutch was slipping. It didnt grind before the swap but now ONLY when i FIRST go into 5th gear, it grinds. I put it into 5th VERY slowly to help prevent transmission damage. i did not get the swap done at a certified shop, it was in a "friends" driveway. I mentioned the 5th gear grind to him and that it didnt do this before the swap so i wanted him to fix it. He then claimed no responsibility "the grind has nothing to do with how the clutch was installed, it has to do with the transmission". A month before the engine blew i went and got the tranny inspected, left with a perfectly clean bill of health so i KNOW its not the transmission. What could have been installed improperly for this to happen? and how do i explain it to him so he knows he's f*cked if he tries to deny that its his fault?! He left my new engine in horrible condition also by not connecting the engine to body harness and messing up quite a few sensors, but thats easily fixed by myself. The clutch issue on the other hand could cost me a couple thousand if it messes up my transmission so im not willing to just let it go. Please, any advice on how he could have installed it wrong would be appreciated!! i'd rather NOT have to take anyone to court.
 
1 - 1 of 1 Posts
Status
Not open for further replies.
Top