Chevy Cobalt Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey Guys! Im brand new here, but im looking for someone to help guide me and almost be a Cobalt therapist for me, because i have alot of issues. If you would like to message me please do! Thank you i really do appreciate it.
 

·
Registered
Joined
·
896 Posts
There are several folks around that can help you with the issues your having with your Cobalt.
Be brave and give us more details.
1 what year and model Cobalt you have..depending upon the trim level and your particular problem, help us out so we are not guessing. Ie there is no clutch position switch on an automatic. And there is no shift lever interlock switch on a standard.
2 as best as you can say what the issue is and what you have done to confirm or address it. A quick read with a code scanner can go a long way.
3 be patient. For free help is not always only milliseconds away.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Well, I have a 2010 Cobalt 2.2 LT Automatic Tranny (yes i know nothing special, but i still absolutely love it and want to keep it for as long as i can.) So i put and after market 3 inch catback exhaust on it and a cold air intake as mods, there is alot of problems im having, ive done code reads and everything, and ive spent alot of money trying to fix it. So first one is something that arose recently, so just before i put the catback exhaust on, my exhaust sometimes would shake very violently, so i thought it was an exhaust leak because i had just a muffler with some exhaust pipe from an auto store, and the pipes were just clamped onto eachother, so i put the new one on and it still makes the noise and it stills shakes violently, someone said a misfire maybe? Second problem is my car is drinking gas, my computer says 21.5 mpg but i think i only get 200 miles per tank, i think my car is running lean or rich due to the intake mod, but im not sure. Next problem is that to me my car does not feel like a 2500lb 155hp car, it just feels sluggish and sometimes when i push all the way down on the gas it wont go any faster, my car runs like it has bipolar, sometimes it runs good and sometimes it runs really bad. Another problem is my driverside tire moves back and forth when braking, almost like my control arm bushings are gone, which ive bought most of the front end stuff like control arms. Next problem... i believe its the valve cover gaskets and all that but oil is getting into the air intake from the valve cover ventilation or crankcase ventilation port, and oil is also getting into and on a spark plug and ignition coil into a cylinder, i bought the gaskets and O rings but im inexperienced in taking the valve cover off and dont really want to mess it up if there is a way. Also i believe my timing tensioners are out because its almost like i can hear it while the engine is running. (I also bought the whole kit for it, dont know how to do it and i know you can really mess up that)
Theres most of my problems if i think of more ill make sure to post them. Thank you for your help i really do appreciate it.
 
1 - 3 of 3 Posts
Top